Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 авг 2021, 14:22

Отбор строк в табличном поле

Автор AVTOREGION, 29 июн 2021, 13:25

0 Пользователей и 1 гость просматривают эту тему.

AVTOREGION

Ребята помогите сделать отбор в табличном поле (обведен красным цветом).
Это главное окно при запуске, в нем установлено табличное поле которое из ДокументовЗаказы отображает список заказов. Так вот нужно что бы в этом поле отображались только заказы у которых нет флага закрыт.
Отбор и ОтборСтрок не срабатывает, либо делаю что-то не так.
Заранее всем спасибо за помощь.FastStoneEditor1.jpg

AVTOREGION

Доп.

Использую пока альтернативу, но она всего лишь скрывает текст грубо говоря, а строка весит.


Если ДанныеСтроки.Архив = Истина Тогда 
Для каждого мЯчейка из ОформлениеСтроки.Ячейки  цикл
мЯчейка.Видимость = ложь;
   КонецЦикла; 
   КонецЕсли;

LexaK

так у вас вроде обычные формы...
попробуйте Список не на основании журнала делать, а прямо из типа ДокументСписок.Заказы (как там у вас)
и тогда в модуле формы, в процедуре ПриОткрытии можно добавить свой отбор, вот пример
(с журналом тоже как-то можно настроить отбор, но сложнее)

Процедура ПриОткрытии()
// Вставить содержимое обработчика.
лкОтбор = ЭлементыФормы.ТаблицаСписок.Значение.Отбор;
лкОтбор.Статус.Использование = Истина;
лкОтбор.Статус.Значение = Перечисления.СтатусыЗаказовКлиентов.Закрыт;
    лкОтбор.Статус.ВидСравнения = ВидСравнения.НеРавно;
КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

AVTOREGION

Цитата: LexaK от 29 июн 2021, 14:11так у вас вроде обычные формы...
попробуйте Список не на основании журнала делать, а прямо из типа ДокументСписок.Заказы (как там у вас)
и тогда в модуле формы, в процедуре ПриОткрытии можно добавить свой отбор, вот пример
(с журналом тоже как-то можно настроить отбор, но сложнее)

Процедура ПриОткрытии()
// Вставить содержимое обработчика.
лкОтбор = ЭлементыФормы.ТаблицаСписок.Значение.Отбор;
лкОтбор.Статус.Использование = Истина;
лкОтбор.Статус.Значение = Перечисления.СтатусыЗаказовКлиентов.Закрыт;
    лкОтбор.Статус.ВидСравнения = ВидСравнения.НеРавно;
КонецПроцедуры

Красавчик, неделю мучаюсь... Спасибо милый человек, все заработало. :zebzdr:
Тему можно закрывать.

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск