Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 окт 2021, 13:58

КА 2.4 выдает ошибка при работе с иностранными контрагентами "Реализация"

Автор Сергей Поляков, 28 июн 2021, 03:13

0 Пользователей и 1 гость просматривают эту тему.

Сергей Поляков

Всем здравствуйте.
Подскажите может кто сталкивался?
КА 2.4.13.209 (после обновления, Начиная с версии 2.4.13.203 и по текущую)
при создании реализации товаров услуг и выборе иностранного контрагента, при проведении выдает ошибку.
также при открытии старых, ранее введенных документов, где указан иностранный контрагент, выдает эту же ошибку, документы не открываются.
"Преобразование значения к типу Булево не может быть выполнено".
тоже самое и на второй базе, обе базы типовые.
делаю вывод что ошибка в самой программе, но как исправить не понятно, 1С пока ошибку не зарегистрировали.
может кто подскажет? спасибо.


Сергей Поляков

@ГеннадийОбьГЭС спасибо за статью.
в отладчике когда я открываю документ он ссылается вот на это:
Общий модуль ОбщегоНазначенияУТКлиент
Процедура ИзменитьЭлемент(Список) Экспорт
ТекущиеДанные = Список.ТекущиеДанные;
Если ТекущиеДанные <> Неопределено И ЗначениеЗаполнено(ТекущиеДанные.Ссылка) Тогда
ПоказатьЗначение(Неопределено, ТекущиеДанные.Ссылка);
КонецЕсли;
КонецПроцедуры

//собственно на этой процедуре и затык, но условие равно Истина, текущие данные ссылку на документ содаржат. Ставлю точку останова и через клавицу F11 пробую идти дальше, и просто вылетает еще раз окно "Преобразование значения к типу Булево не может быть выполнено".
может быть дело не в конфигураторе, а в платформе, и ее нужно обновить? т.к. что дальше делать не пойму.

DmitriyF

Цитата: Сергей Поляков от 29 июн 2021, 06:04@ГеннадийОбьГЭС спасибо за статью.
в отладчике когда я открываю документ он ссылается вот на это:
Общий модуль ОбщегоНазначенияУТКлиент
Процедура ИзменитьЭлемент(Список) Экспорт
ТекущиеДанные = Список.ТекущиеДанные;
Если ТекущиеДанные <> Неопределено И ЗначениеЗаполнено(ТекущиеДанные.Ссылка) Тогда
ПоказатьЗначение(Неопределено, ТекущиеДанные.Ссылка);
КонецЕсли;
КонецПроцедуры

//собственно на этой процедуре и затык, но условие равно Истина, текущие данные ссылку на документ содаржат. Ставлю точку останова и через клавицу F11 пробую идти дальше, и просто вылетает еще раз окно "Преобразование значения к типу Булево не может быть выполнено".
может быть дело не в конфигураторе, а в платформе, и ее нужно обновить? т.к. что дальше делать не пойму.
В конфигураторе нужно понимать, что и как, в вашей ситуации попробуйте проверить, может патч какой вышел в котором это добро исправлено. И как вариант ТИИ с чисткой кэша сделайте

Сергей Поляков

ну отладчиком я пользоваться умею.
кэш чистили, не помогло.
а вот насчет патчей, я пробовал и установить все дополненния, и удалитьв се расширения в конфигураторе, ничего не помогает.

DmitriyF

Цитата: Сергей Поляков от 29 июн 2021, 10:36ну отладчиком я пользоваться умею.
кэш чистили, не помогло.
а вот насчет патчей, я пробовал и установить все дополненния, и удалитьв се расширения в конфигураторе, ничего не помогает.

Ну если умеешь то смотри где у тебя идет сравнение и что сравнивает. Попробуй кстати создать нового контрагента для проверки и сделай реализацию. Кстати обработчики после обновления все отработали?

Геннадий ОбьГЭС

Цитата: Сергей Поляков от 29 июн 2021, 10:36а вот насчет патчей, я пробовал и установить все дополненния, и удалитьв се расширения в конфигураторе
Удалять надо бы только отозванные и после установки расширений, не удаляя все!

Цитрую багтрекер по НЕКОТОРЫМ:
- "Планируется исправление в будущих версиях"
- Принята к исправлению
- находится на рассмотрении
ошибкам, содержащим "иностранн*" и "Преобразование значения к типу Булево не может быть выполнено" среди УТ11-КА2 ЕРП2 :
  • https://bugboard.v8.1c.ru/error/000109790

    Ошибка 00-00365475
    Код ошибки: 00-00365475
    Код(ы) обращения: Росатом
    Статус: Планируется исправление в будущих версиях Зарегистрирована: 18.05.2021
    Планируется исправить: "1С:ERP Управление предприятием 2.0", версия 2.5.7 (устар)

    Описание:
    В ГФУ расчетов с признаком "Ведется учет расчетов в иностранной валюте" не выбирается счет 76.ОК

    Способ обхода:
    В ГФУ выполнить последовательно:
    - отключить «Ведется учета расчетов в иностранной валюте»,
    - установить счет для «Товары к оформлению» (76.ОК),
    - после этого вновь установить «Ведется учета расчетов в иностранной валюте»
  • https://bugboard.v8.1c.ru/error/000101226

    Ошибка 00-00337911
    Код ошибки: 00-00337911
    Код(ы) обращения: HL-246323
    Статус: Исправлена в выпущенной версии
    Зарегистрирована: 02.12.2020
    Планируется исправить: "1C:Комплексная автоматизация, редакция 2.0", версия 2.5.5
    Исправлена: "1C:Комплексная автоматизация, редакция 2.0", версия 2.4.13.96

    Описание:
    При попытке проведения документа Списание безналичных ДС (операция: Конвертация валюты), если до него уже проводилось Списание по другой иностранной валюте, но с тем же счетом зачисления, выходит следующая ошибка и документ не проводится:
    Запись с такими ключевыми полями существует! : ГрафикПлатежей: *, *, *, *, *, *, Реализация иностранной валюты, Поступление, RUB (Регистр сведений: График платежей; Номер строки: 2)

  • https://bugboard.v8.1c.ru/error/000098357

    Ошибка 00-00325264
    Код ошибки: 00-00325264
    Код(ы) обращения: HL-213616
    Статус: Исправлена в выпущенной версии
    Зарегистрирована: 14.09.2020
    Исправлена: "1C:Комплексная автоматизация, редакция 2.0", версия 2.4.13.46
    Исправлена: "1C:Комплексная автоматизация, редакция 2.0", версия 2.5.5.94 (для тестирования)

    Описание:
    При отражении в регламентированном учёте документа Списание безналичных ДС, в котором объекты расчетов оплачиваются в рублях, а взаиморасчеты в иностранной валюте, может задваиваться сумма в проводке.

    Способ обхода:
    Скорректировать сумму проводки ручной корректировкой.

    Способ исправления:
    В общем модуле "СписаниеБезналичныхДенежныхСредствЛокализация", в методе "ТекстЗапросаВТОтраженияВРеглУчете", область "ДенежныеСредстваКонтрагент" в тексте запроса, в разделе группировки (после строки "СГРУППИРОВАТЬ ПО") удалить строку "ДвиженияДенежныеСредстваКонтрагент.ОбъектРасчетов,"


  • Ошибка 00-00378018
    Код ошибки: 00-00378018
    Код(ы) обращения: FR-744281
    Статус: На рассмотрении
    Зарегистрирована: 05.07.2021
    Продукт: "1С:КА2"

    Описание:
    Ошибка находится на рассмотрении.

    Из списка "Документы продажи (все)" открываем документ реализации товаров и услуг - ошибка: "Преобразование значения к типу Булево не может быть выполнено".

  • Ошибка 00-00346298
    Код ошибки: 00-00346298
    Код(ы) обращения: HL-271121
    Статус: Исправлена в выпущенной версии
    Зарегистрирована: 28.01.2021

    Исправлена: "1С:КА2", версия 11.5.6.137 (для тестирования)

    Описание:
    Если после загрузки счет-фактуры полученного не загружен документ основание и в соответствующем поле битая ссылка, то загруженный документ не открывается с ошибкой: Преобразование значения к типу Булево не может быть выполнено.



  • Ошибка 00-00343040
    Код ошибки: 00-00343040
    Статус: Исправлена в тестовой версии
    Зарегистрирована: 12.01.2021
    Исправлена: "1С:КА2", версия 11.5.6.137 (для тестирования)

    Описание:
    При создании на основании заказа документа "Сборка товаров" возникает ошибка
    {ОбщийМодуль.НаправленияДеятельностиСервер.Модуль(202)}: Преобразование значения к типу Булево не может быть выполнено
               И (Не ЗначениеЗаполнено(Форма.Объект[ИмяРеквизитаПоЗаказу]) Или Не Форма.Объект[ИмяРеквизитаПоЗаказу]);

    Способ исправления:
    В общем модуле НаправленияДеятельностиСервер:
    1)  в процедуре УстановитьВидимостьЭлементовОбособленно

    заменить фрагмент кода:

          ОтобразитьЭлементы = ЗначениеЗаполнено(НазначениеПоУмолчанию)
             И (Не ЗначениеЗаполнено(Форма.Объект[ИмяРеквизитаПоЗаказу]) Или Не Форма.Объект[ИмяРеквизитаПоЗаказу]);

    на фрагмент кода:

          ЭтоНакладнаяПоЗаказу = Форма.Объект[ИмяРеквизитаПоЗаказу];
          ЭтоРеквизитБулевогоТипа = ТипЗнч(ЭтоНакладнаяПоЗаказу) = Тип("Булево");
          ОтобразитьЭлементы = ЗначениеЗаполнено(НазначениеПоУмолчанию)
             И (ЭтоРеквизитБулевогоТипа И Не ЭтоНакладнаяПоЗаказу
                Или Не ЭтоРеквизитБулевогоТипа И Не ЗначениеЗаполнено(ЭтоНакладнаяПоЗаказу));

    2)  в процедуре ПриИзмененииНаправленияДеятельности

    заменить фрагмент кода:

          Если ИмяРеквизитаПоЗаказу = Неопределено
             Или Не ЗначениеЗаполнено(Форма.Объект[ИмяРеквизитаПоЗаказу])
             Или Не Форма.Объект[ИмяРеквизитаПоЗаказу] Тогда

    на фрагмент кода:

          ЭтоНакладнаяПоЗаказу = Ложь;
          ЭтоРеквизитБулевогоТипа = Ложь;
          Если ИмяРеквизитаПоЗаказу <> Неопределено Тогда
             ЭтоНакладнаяПоЗаказу = Форма.Объект[ИмяРеквизитаПоЗаказу];
             ЭтоРеквизитБулевогоТипа = ТипЗнч(ЭтоНакладнаяПоЗаказу) = Тип("Булево");
          КонецЕсли;
          
          НазначениеПоУмолчанию = Неопределено;
          Если ИмяРеквизитаПоЗаказу = Неопределено
             Или ЭтоРеквизитБулевогоТипа И Не ЭтоНакладнаяПоЗаказу
             Или Не ЭтоРеквизитБулевогоТипа И Не ЗначениеЗаполнено(ЭтоНакладнаяПоЗаказу) Тогда

    3) в процедуре ПерезаполнитьСлужебныеРеквизитыТабличнойЧасти

    заменить фрагмент кода:

          Если ЗначениеЗаполнено(Кэш.НазначениеПоУмолчанию)
             И (Не ЗначениеЗаполнено(Форма.Объект[ИмяРеквизитаПоЗаказу])
                 Или Не Форма.Объект[ИмяРеквизитаПоЗаказу]) Тогда

    на фрагмент кода:

          ЭтоНакладнаяПоЗаказу = Форма.Объект[ИмяРеквизитаПоЗаказу];
          ЭтоРеквизитБулевогоТипа = ТипЗнч(ЭтоНакладнаяПоЗаказу) = Тип("Булево");
          
          Если ЗначениеЗаполнено(Кэш.НазначениеПоУмолчанию)
             И (ЭтоРеквизитБулевогоТипа И Не ЭтоНакладнаяПоЗаказу
                Или Не ЭтоРеквизитБулевогоТипа И Не ЗначениеЗаполнено(ЭтоНакладнаяПоЗаказу)) Тогда



  • Ошибка 00-00097926
    Код ошибки: 00-00097926
    Статус: Планируется исправление в будущих версиях Зарегистрирована: 11.10.2016
    Продукт: "1С:Управление торговлей 11"

    Описание:
    При записи документа передача между организациями может возникать ошибка:
    {ОбщийМодуль.ОбщегоНазначенияУТКлиент.Модуль(269)}: Преобразование значения к типу Булево не может быть выполнено
       Если Не Результат Тогда
  • Ошибка 00-00027539
    Код ошибки: 00-00027539
    Статус: Планируется исправление в будущих версиях Зарегистрирована: 03.06.2014
    Продукт: "1С:КА2"

    Описание:
    При вводе Приходного ордера на основании некоторых видов распоряжений на поступление (в т.ч. "Выпуск продукции", "Заказ давальца") некорректно заполняется список складов для выбора, что в свою очередь может приводить к ошибке вида: {ОбщийМодуль.НоменклатураСервер.Модуль(713)}: Преобразование значения к типу Булево не может быть выполнено



Геннадий ОбьГЭС

А некоторые при поиске по "ОбщегоНазначенияУТКлиент" :

  • Ошибка 00-00362381
    Код ошибки: 00-00362381
    Код(ы) обращения: HL-326609
    Статус: Отклонена
    Зарегистрирована: 28.04.2021

    Описание:
    При проведении документа "Приобретение товаров и услуг" в клиент-серверном режиме может возникать конфликт блокировок при выполнении транзакции
    Превышено максимальное время ожидания предоставления блокировки
    {ОбщийМодуль.ОбщегоНазначенияУТКлиент.Модуль(1957)}:   Результат = Форма.Записать(ПараметрыЗаписи);
    {Документ.ПриобретениеТоваровУслуг.Форма.ФормаДокумента.Форма(8497)}: ОбщегоНазначенияУТКлиент.ОбработатьЗаписьОбъектаВФорме(ЭтотОбъект, ПараметрыДляЗаписи);

    Способ обхода:
    Изменить расчеты с онлайн на оффлайн и вернуть обратно на онлайн
    (НСИ и Администрирование - Настройки НСИ и разделов - Казначейство и взаиморасчеты - Взаиморасчеты - выбор значения в поле Взаиморасчеты).

    Причина неисправления:
    Не был корректно завершён переход на онлайн расчеты.



  • Ошибка 00-00343630
    Код ошибки: 00-00343630
    Код(ы) обращения: HL-262852
    Статус: Исправлена в тестовой версии
    Зарегистрирована: 14.01.2021
    Исправлена: "1С:Управление торговлей 11", версия 11.5.6.137 (для тестирования)

    Описание:
    На платформе 8.3.18 при открытии документа «Счет-фактура полученный» возникает ошибка
     
    Значение не является значением объектного типа (ВГраница)
    {ОбщийМодуль.РаботаСФайламиКлиент.Модуль(1438)}:    Для ИндексЭлемента = 0 По Форма.ПараметрыРаботыСФайлами.ВГраница() Цикл
    {ОбщийМодуль.РаботаСФайламиКлиент.Модуль(593)}:                       ИзменитьВидимостьДополнительныхКоманд(Форма);
    {Документ.СчетФактураПолученный.Форма.ФормаДокумента.Форма(188)}:                РаботаСФайламиКлиент.ПриОткрытии(ЭтотОбъект, Отказ);
    {ОбщийМодуль.ОбщегоНазначенияУТКлиент.Модуль(275)}:                            ПоказатьЗначение(Неопределено, ТекущиеДанные.Ссылка);
    {Обработка.ЖурналДокументовЗакупки.Форма.СписокДокументов.Форма(330)}:                ОбщегоНазначенияУТКлиент.ИзменитьЭлемент(Элемент);

    Способ исправления:
    Способ исправления в конфигураторе:
    1. Снять с поддержки форму документа Счет-фактура полученный.
    2. Открыть форму, удалить реквизиты формы ПараметрыРаботыСФайлами и ОформленПоАвансовомуОтчету.
    3. Добавить реквизит формы ПараметрыРаботыСФайлами с типом Произвольный
    4. Добавить реквизит формы ОформленПоАвансовомуОтчету с типом Булево


Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск