Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 01:20

Открыть форму константы

Автор cobra77777, 27 июн 2021, 15:36

0 Пользователей и 1 гость просматривают эту тему.

cobra77777

Здравствуйте! Платформа 8.3.18.1208. Управляемые формы.

Пытаюсь открыть форму в модуле приложения:

Процедура ПриНачалеРаботыСистемы()
   
   Форма = ПолучитьФорму ("ОбщаяФорма.ФормаКонстант");
   Форма.Открыть();

КонецПроцедуры

Выходит ошибка: Недостаточно прав для просмотра. Где косяк?

Спасибо

Ивашка

Цитата: cobra77777 от 27 июн 2021, 15:36Здравствуйте! Платформа 8.3.18.1208. Управляемые формы.

Пытаюсь открыть форму в модуле приложения:

Процедура ПриНачалеРаботыСистемы()

Форма = ПолучитьФорму ("ОбщаяФорма.ФормаКонстант");
Форма.Открыть();

КонецПроцедуры

Выходит ошибка: Недостаточно прав для просмотра. Где косяк?

Спасибо

попробуйте вместо ПолучитьФорму использовать ОткрытьФорму
Процедура ПриНачалеРаботыСистемы()

ОткрытьФорму("ОбщаяФорма.ФормаКонстант");

КонецПроцедуры

cobra77777

Выходит ошибка: Неизвестное имя формы (скриншот прикр.)


Ивашка

Цитата: cobra77777 от 28 июн 2021, 08:28Выходит ошибка: Неизвестное имя формы (скриншот прикр.)


а так?
ОткрытьФорму("ОбщаяФорма.Форма.ФормаКонстант")

cobra77777


Ивашка

Ошибка платформы либо форма не так называется, покажите структуру формы?

cobra77777

вот

Ивашка

Цитата: cobra77777 от 28 июн 2021, 09:10вот
А где сама форма находится? Че то я не понял

cobra77777


Ивашка

Цитата: cobra77777 от 28 июн 2021, 09:15здесь
Как я и думал, у тя форма называется Наименование а не ФормаКонстант
ОткрытьФорму("ОбщиеФормы.Форма.Наименование")

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск