Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 00:55

Помогите. Ошибка: "Получение элемента по индексу для значения не определено"

Автор Arabli, 24 июн 2021, 05:11

0 Пользователей и 1 гость просматривают эту тему.

Arabli

Не могу разобраться, в чем ошибка, помогите, пожалуйста((
Я только начинаю осваивать 1с
Сам код здесь:
&НаКлиенте
Процедура ИскатьСервер(Направление) Экспорт
СписокПоиска = ПолнотекстовыйПоиск.СоздатьСписок();
СписокПоиска.СтрокаПоиска = ПоисковоеВыражение;
Если Направление = 0 Тогда
   СписокПоиска.ПерваяЧасть();
ИначеЕсли Направление = -1 Тогда
   СписокПоиска.ПредыдущаяЧасть(ТекущаяПозиция);
ИначеЕсли Направление = 1 Тогда
   СписокПоиска.СледующаяЧасть(ТекущаяПозиция);
КонецЕсли;
РезультатыПоиска.Очистить();
Для Каждого Результат Из СписокПоиска Цикл
   РезультатыПоиска.Добавить(Результат.Значение);
КонецЦикла;
РезультатПоиска = СписокПоиска.ПолучитьОтображение(ВидОтображенияПолнотекстовогоПоиска.HTMLТекст);
ТекущаяПозиция = СписокПоиска.НачальнаяПозиция();
ПолноеКоличество1 = СписокПоиска.ПолноеКоличество();

Если СписокПоиска.Количество()<>0 Тогда
   СообщениеОРезультате = "Показаны "+Строка(ТекущаяПозиция+1)+"-"+
   Строка(ТекущаяПозиция+СписокПоиска.Количество())+" из "+
   Строка(ПолноеКоличество1);
   Элементы.СледующаяПорция.Доступность = (ПолноеКоличество1-ТекущаяПозиция)>СписокПоиска.Количество();
   Элементы.ПредыдущаяПорция.Доступность = (ТекущаяПозиция>0);
Иначе
   СообщениеОРезультате="Не найдено";
      Элементы.СледующаяПорция.Доступность = Ложь;
      Элементы.ПредыдущаяПорция.Доступность = Ложь;
      КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура РезультатПоискаПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
   ЭлементHTML= ДанныеСобытия.Event.srcElement;
   Если (ЭлементHTML.id = "FullTextSearchListItem") Тогда
      НомерВСписке = Неопределено;
      Попытка
         НомерВСписке = Число(ЭлементHTML.nameProp);
      Исключение
         Попытка
            НомерВСписке = Число(ЭлементHTML.getattribute("sel_num"));
         Исключение
         КонецПопытки;
      КонецПопытки;
      ВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;
      ОткрытьЗначение(ВыбраннаяСтрока);
      СтандартнаяОбработка = Ложь;
   КонецЕсли;
КонецПроцедуры
   

Геннадий ОбьГЭС

Конфигурация типовая?
Наименование и полная версия?
Ошибка - в результате (после) чего именно?
Каких действий?

Геннадий ОбьГЭС

 "Получение элемента по индексу для значения не определено" - Это часто втречающая ошибка в обработках, разработанных под обычное приложение, а конфигурация используется в управляемом
(что не исключает ее запуск под обычным)

Arabli

Цитата: Геннадий ОбьГЭС от 24 июн 2021, 06:36Конфигурация типовая?
Наименование и полная версия?
Ошибка - в результате (после) чего именно?
Каких действий?
Немного не понимаю слово "Типовая"
1С Предприятие 8.3.16.1030
Ошибка возникает, когда я в форме отчета нашел ссылки на элементы в справочниках и документах. Затем я пытался перейти по ним, чтобы открыть их форму элемента (скрин прилагаю: https://imgur.com/a/8Ozmhvh)

Геннадий ОбьГЭС

Какого отчета?
А после нажатия на "Подробно" - что выдаётся?
Наименование и версия конфигурации - какие?
На скриншоте этой информации -  нет!

"Типовая" - это не разработанная Вами самим,
а скачанная из сайта 1С
https://releases.1c.ru/total

Поиск на баг-трекере
https://bugboard.v8.1c.ru/search
по Вашим (неполным данным) данным по ошибке:
"Получение элемента по индексу для значения не определено"
выдаёт под сотню описаний ошибок

Arabli

Цитата: Геннадий ОбьГЭС от 24 июн 2021, 09:54Какого отчета?
А после нажатия на "Подробно" - что выдаётся?
Наименование и версия конфигурации - какие?
На скриншоте этой информации -  нет!

"Типовая" - это не разработанная Вами самим,
а скачанная из сайта 1С
https://releases.1c.ru/total

Поиск на баг-трекере
https://bugboard.v8.1c.ru/search
по Вашим (неполным данным) данным по ошибке:
"Получение элемента по индексу для значения не определено"
выдаёт под сотню описаний ошибок
Отчёт Поискданных2, база своя, а не скаченная из интернета.
Выше я скидывал, 1С Предприятие 8.3.16.1030

Arabli

Цитата: Arabli от 24 июн 2021, 10:35
Цитата: Геннадий ОбьГЭС от 24 июн 2021, 09:54Какого отчета?
А после нажатия на "Подробно" - что выдаётся?
Наименование и версия конфигурации - какие?
На скриншоте этой информации -  нет!

"Типовая" - это не разработанная Вами самим,
а скачанная из сайта 1С
https://releases.1c.ru/total

Поиск на баг-трекере
https://bugboard.v8.1c.ru/search
по Вашим (неполным данным) данным по ошибке:
"Получение элемента по индексу для значения не определено"
выдаёт под сотню описаний ошибок
Отчёт Поискданных2, база своя, а не скаченная из интернета.
Выше я скидывал, 1С Предприятие 8.3.16.1030, могу выгруженный файл скинуть

Вот ссылка с информацией об моей конфигурации: https://imgur.com/a/0VyFyZy

LexaK

нуууу, даааа, оооо

судя по наименованию ошибки, и тому коду что вы выложили, ошибка здесь
ЦитироватьВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;

исправить ее, для вашего варианта можно так

&НаКлиенте
Процедура РезультатПоискаПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
   ЭлементHTML= ДанныеСобытия.Event.srcElement;
   Если (ЭлементHTML.id = "FullTextSearchListItem") Тогда
      НомерВСписке = Неопределено;
      Попытка
         НомерВСписке = Число(ЭлементHTML.nameProp);
      Исключение
         Попытка
            НомерВСписке = Число(ЭлементHTML.getattribute("sel_num"));
         Исключение
         КонецПопытки;
КонецПопытки;
Попытка
      ВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;
      ОткрытьЗначение(ВыбраннаяСтрока);
Исключение
ПоказатьПредупреждение(,"Нет данных для просмотра",20);
КонецПопытки;
      СтандартнаяОбработка = Ложь;
   КонецЕсли;
КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

Arabli

Цитата: LexaK от 24 июн 2021, 11:34нуууу, даааа, оооо

судя по наименованию ошибки, и тому коду что вы выложили, ошибка здесь
ЦитироватьВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;

исправить ее, для вашего варианта можно так

&НаКлиенте
Процедура РезультатПоискаПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
   ЭлементHTML= ДанныеСобытия.Event.srcElement;
   Если (ЭлементHTML.id = "FullTextSearchListItem") Тогда
      НомерВСписке = Неопределено;
      Попытка
         НомерВСписке = Число(ЭлементHTML.nameProp);
      Исключение
         Попытка
            НомерВСписке = Число(ЭлементHTML.getattribute("sel_num"));
         Исключение
         КонецПопытки;
КонецПопытки;
Попытка
      ВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;
      ОткрытьЗначение(ВыбраннаяСтрока);
Исключение
ПоказатьПредупреждение(,"Нет данных для просмотра",20);
КонецПопытки;
      СтандартнаяОбработка = Ложь;
   КонецЕсли;
КонецПроцедуры

Сейчас проверю

Arabli

Цитата: LexaK от 24 июн 2021, 11:34нуууу, даааа, оооо

судя по наименованию ошибки, и тому коду что вы выложили, ошибка здесь
ЦитироватьВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;

исправить ее, для вашего варианта можно так

&НаКлиенте
Процедура РезультатПоискаПриНажатии(Элемент, ДанныеСобытия, СтандартнаяОбработка)
   ЭлементHTML= ДанныеСобытия.Event.srcElement;
   Если (ЭлементHTML.id = "FullTextSearchListItem") Тогда
      НомерВСписке = Неопределено;
      Попытка
         НомерВСписке = Число(ЭлементHTML.nameProp);
      Исключение
         Попытка
            НомерВСписке = Число(ЭлементHTML.getattribute("sel_num"));
         Исключение
         КонецПопытки;
КонецПопытки;
Попытка
      ВыбраннаяСтрока  = РезультатыПоиска[НомерВСписке].Значение;
      ОткрытьЗначение(ВыбраннаяСтрока);
Исключение
ПоказатьПредупреждение(,"Нет данных для просмотра",20);
КонецПопытки;
      СтандартнаяОбработка = Ложь;
   КонецЕсли;
КонецПроцедуры

ладно, как обход пойдет
Просто я понять не могу, почему не открывается форма элемента номенклатуры, когда нажимаю на гиперссылку

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск