Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2021, 20:21

Работа с картинками в 1С

Автор PushGun, 07 июн 2021, 06:45

0 Пользователей и 1 гость просматривают эту тему.

PushGun

Проблема такая, открываю форму констант, выбираю картинку, она устанавливается и даже сохраняется, но появляется ошибка, помогите решить. Ошибка появляется при установке картинки.
&НаКлиенте
Процедура ФотоНажатие(Элемент, СтандартнаяОбработка)
ИмяФайла = "";
ПутьФайла = "";

Если ПоместитьФайл(ПутьФайла, , ИмяФайла, Истина, Новый УникальныйИдентификатор) = Истина Тогда

Фото = ПутьФайла;

УстановитьКартинку();
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура УстановитьКартинку()
НовыйФайлКартинки = Справочники.Файлы.СоздатьЭлемент();
НовыйФайлКартинки.Файл = Новый ХранилищеЗначения(ПолучитьИзВременногоХранилища(Фото));
Фото = ПоместитьВоВременноеХранилище(НовыйФайлКартинки.Файл.Получить(), Новый УникальныйИдентификатор);

НовыйФайлКартинки.Записать();

Константы.Фото.Установить(НовыйФайлКартинки.Ссылка);
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
Фото = ПолучитьНавигационнуюСсылку(Константы.Фото.Получить(), "Файл");
Элементы.Фото.РазмерКартинки = РазмерКартинки.АвтоРазмер;
КонецПроцедуры



PushGun

Проблема решена, это была не ошибка, а в окне прописывался адрес, где находится картинка. Нужно было в процедуре команды у параметра "СтандартнаяОбработка" указать значение "Ложь".

Похожие темы (2)

Рейтинг@Mail.ru Rambler's Top100

Поиск