Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:43
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Ни как не удалить документы в 1С!!! ХЕЛП!!!!  (Прочитано 18095 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ольга Николаева

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Бухгалтер
Подскажите, пожалуйста. Мне надо удалить почти все документы, но не удалять номенклатуру.
Вошла в 1С, как администратор, монопольно. Пометила все документы на удаление. Открыла удаление помеченных объектов. Но документы как были, так и есть. Они НЕ удаляются. Пишет, что удалить невозможно. Что делать?????? :dfbsdfbsdf:


Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Некоторые документы всеже удалились? Если помечены не все документы, то в этих непомеченных документах есть ссылки на помеченные. (тоисть вы делали например "Ввод на основании"). е еще в документах которые непомечены на удаление есть товар(номенклатура) которая например была в документе "приход" - который вы питаетесь удалить. такое невозможно сделать. И почему все документы не пометили? непонятна суть почему нужно удалять не все документы.

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
//нужна небольшая обработка (если документы действительно не нужны), в личку обращайтесь напишу.
// для форума (хотя и так все знают)
Процедура Сформировать()
Док = СоздатьОбъект("Документ");
Док.ВыбратьДокументы();
Пока Док.ПолучитьДокумент() = 1 Цикл
Док.Удалить(1);
КонецЦикла;
КонецПроцедуры


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
ну дык я и говорю что это несоветский такой метод, если
"документы действительно не нужны"

Оффлайн Ольга Николаева

  • *
  • Сообщений: 10
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Бухгалтер
Спасибо. Всё сделала! :D

Оффлайн maleks

  • *
  • Сообщений: 8
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-09-06
  • Сайт: 
  • Профессия: Ученик 1С
а подскажите, как пометить на удаление все документы, а не тыкать на каждый по отдельности? заранее спасибо.

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
написать обработку которая это сделает....

Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Вот пример для пометки на удаления расходных накладных
Процедура Сформировать()
Док3=СоздатьОбъект("Документ.РасходнаяНакладная");
Док3.ВыбратьДокументы(Дата1,ДатаПо); 
Пока Док3.ПолучитьДокумент()=1 Цикл 
Сообщить("Розх. накл. "+Док3.ДатаДок+"  "+Док3.НомерДок);
    Док3.Удалить(0);
КонецЦикла;
Сообщить("Расхожные накладные помеченные на удаления");
КонецПроцедуры

Процедура ПриОткрытии() 
Дата1 = "01.01.2000";
ДатаПо = "01.01.2000";

КонецПроцедуры


Оффлайн volodya1122

  • ***
  • Сообщений: 215
  • РЕПУТАЦИЯ: 31
  • КПД: 14%
  • Регистрация: 2011-01-24
  • Сайт: 
  • Профессия: Программист 7.7
Если вообще все документы за выбраный период то изменить код
СоздатьОбъект("Документ.РасходнаяНакладная");
на
СоздатьОбъект("Документ");

Оффлайн Таня222

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2012-02-28
  • Сайт: 
  • Профессия: Ученик 1С
Помогите пожалуйста с проблемой.
помечаю на удаление накладные на реализацию через обработку док.все накладные помечены,открываю "удаление пом. объектов" в поле где должны быть все док. помеченные на удаление из допустим 20 накладных только 3,нажимаю поиск ничего не происходит.т.е не выводятся помеченные на удаление документы в поле контроля.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 127
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal