Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2021, 20:46

Условие if else

Автор pouyo, 29 мая 2021, 09:11

0 Пользователей и 1 гость просматривают эту тему.

pouyo

Здравствуйте! Не могу понять почему у меня не работает условие: ЗначСправВидЖивотного = "Собака". Я новичок в 1С, буду благодарен любой помощи.

&НаСервере
Функция ЗначениеСправочника(Объект, ИмяРеквизита)
Возврат Объект[ИмяРеквизита];
КонецФункции

&НаКлиенте
Процедура СписокКормовКормПриИзменении(Элемент)

ТекущаяСтрока = Элементы.СписокКормов.ТекущиеДанные;
ТекущаяСтрока.Калорийность = ЗначениеСправочника(ТекущаяСтрока.Корм,"Калорийность");
ЗначСправВозраст = ЗначениеСправочника(Объект.Животное,"ВозрастЖивотного");
ЗначСправВидЖивотного = ЗначениеСправочника(Объект.Животное,"ВидЖивотного");
ЗначСправПолЖивотного = ЗначениеСправочника(Объект.Животное,"ПолЖивотного");
ЗначСправИдеальныйВес = ЗначениеСправочника(Объект.Животное,"ИдеальныйВесЖивотного");

Если ЗначСправВозраст < 1 И ЗначСправВидЖивотного = "Собака"  ТОГДА

ТекущаяСтрока.ДневнаяНорма = (132*(pow(ЗначСправИдеальныйВес,0.75)))*0.5;
ТекущаяСтрока.ДневнаяНормаГР = (ТекущаяСтрока.ДневнаяНорма/ТекущаяСтрока.Калорийность)*1000;

КонецЕсли

КонецПроцедуры

nvj84

Реквизит ВидЖивотного скорее всего не строкового типа, а перечисление например. В отладке посмотрите что в ЗначСправВидЖивотного.

pouyo

Цитата: nvj84 от 29 мая 2021, 09:56
Реквизит ВидЖивотного скорее всего не строкового типа, а перечисление например. В отладке посмотрите что в ЗначСправВидЖивотного.
Реквизит ВидЖивотного, находящийся в справочнике Животное, ссылается на справочник ВидЖивотного

antoneus


Если ЗначСправВозраст < 1 И Строка(ЗначСправВидЖивотного) = "Собака"  Тогда

pouyo

Цитата: antoneus от 29 мая 2021, 10:21

Если ЗначСправВозраст < 1 И Строка(ЗначСправВидЖивотного) = "Собака"  Тогда

Сработало! Больше спасибо!

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск