Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июл 2021, 08:03

Действия вычилений с элементами массива

Автор Шамиль 2210, 27 мая 2021, 13:26

0 Пользователей и 1 гость просматривают эту тему.

Шамиль 2210

Здраствуйте! Проводил три варианта вычилений с числами массива, ответа получил только два "сложение" и "умножение", по "Сумма квадратов" ответа нет :angry: Подскажите пожалуйста где ошибся!

Шамиль 2210

Функция Список (Действие, Числа) Экспорт   
   
   Если Действие = "*"  Тогда
      Акк = 1;
   ИначеЕсли Действие = "+" Тогда
      Акк = 0;     
   ИначеЕсли Действие = "Сумма квадратов" Тогда
      Акк = 1*1;     
   Иначе
      Возврат "Ошибка";
   КонецЕсли;   
   
   Для Каждого Элм Из Числа Цикл
      Если Действие = "*" Тогда
         Акк = Акк * Элм;
         ИначеЕсли Действие = "+" Тогда
         Акк = Акк + Элм;
      ИначеЕсли Действие = "Сумма квадратов" Тогда
         Акк = Акк + Элм * Элм;     
      КонецЕсли;
   КонецЦикла;
        Возврат Акк;

      
КонецФункции

antoneus

Видимо, Действие не равно "Сумма квадратов". Код вызова функции какой?

LexaK

там где у вас на второй картинке, добавьте такой код


Рез = Вычисления.Список("Сумма квадратов", КучкаЧисел);
Сообщить(Рез);

ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск