Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 июл 2021, 16:59

1C подменяет колонтитулы при печати в двоичном макете

Автор Pimp, 26 мая 2021, 12:58

0 Пользователей и 1 гость просматривают эту тему.

Pimp

Добрый день.
В базе есть макет .docx двоичные данныее, в нем в Ворде задан колонтитул нумерация страниц. Но 1С заменяет этот колонтитул на пустой.
Как отключить эту замену 1Ской? Используются  стандартные общие модули по печати...
Вот код процедуры которая запускает:

      ПечатнаяФорма = УправлениеПечатью.СведенияОПечатнойФорме(КоллекцияПечатныхФорм, "ВПФ_ПисьмоПЗ_Гос");
   Если ПечатнаяФорма <> Неопределено Тогда
      
      ИмяМакета = "ПФ_DOC_ПисьмоПЗ_ГЭ";
      МакетИДанныеОбъекта = УправлениеПечатьюВызовСервера.МакетыИДанныеОбъектовДляПечати("Обработка.ПечатьПисьмаСПредварительнымиЗамечаниями", ИмяМакета, МассивОбъектов);
      
      ОфисныеДокументы = Новый Соответствие;
      
      //Шаблон = НСтр("ru = '[Контрагент] Договор №[Номер] от [Дата]'");
      //ЗначенияРеквизитовДокументов = ОбщегоНазначения.ЗначенияРеквизитовОбъектов(МассивОбъектов, "Заявитель,Номер,Дата,Ссылка");
      Для Каждого Ссылка Из МассивОбъектов Цикл
         
         //ЗначенияРеквизитовДокумента = ЗначенияРеквизитовДокументов[Ссылка];
         //ЗначенияРеквизитовДокумента.Дата = Формат(ЗначенияРеквизитовДокумента.Дата, "ДЛФ=D");
         //ЗначенияРеквизитовДокумента.Номер = ПрефиксацияОбъектовКлиентСервер.НомерНаПечать(ЗначенияРеквизитовДокумента.Номер);
         //ИмяДокумента = СтроковыеФункцииКлиентСервер.ВставитьПараметрыВСтроку(Шаблон, ЗначенияРеквизитовДокументов[Ссылка]);
      
         Если Ссылка.ТипГрафика = Перечисления.пра_ТипыГрафика.Первичный Тогда
      ИмяДокумента = "Предварительные замечания"+"_"+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd")+"_"+СтрЗаменить(Формат(ТекущаяДата(),"ДЛФ=T"),":","-");
         Иначе
      ИмяДокумента = "Неустраненные замечания"+"_"+СокрЛП(Ссылка.НомерГрафика)+"__"+Формат(ТекущаяДата(),"ДФ=yyyy-MM-dd")+"_"+СтрЗаменить(Формат(ТекущаяДата(),"ДЛФ=T"),":","-");
         КонецЕсли;
   
         
         АдресХранилищаОфисныйДокумент = НапечататьПисьмоСЗамечаниямиГос(Ссылка, МакетИДанныеОбъекта, ИмяМакета, ПараметрыПечати);
         
         ОфисныеДокументы.Вставить(АдресХранилищаОфисныйДокумент, ИмяДокумента);
         
         КаталогОбъекта = УправлениеЭкспертизамиСервер.ПолучитьКаталогФайловЗаявления(Ссылка.Заявление)+ "\Переписка с заказчиком\";
                  
      КонецЦикла;
            
      ПечатнаяФорма.СинонимМакета    = НСтр("ru = 'Письмо с предварительными замечаниями'");
      ПечатнаяФорма.ОфисныеДокументы = ОфисныеДокументы;
      ПечатнаяФорма.КаталогОбъекта = КаталогОбъекта;
      
   КонецЕсли;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск