Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
24 июл 2021, 08:50

Не правильно выводит область в Таб.Док

Автор Алексей_1985_06, 22 мая 2021, 12:56

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Уважаемые программисты, подскажите в чем ошибка, ни как сам не могу разобраться. Документ выводится на печать, но по какой-то причине при предпросмотре и печати сам лист не до конца заполняется строками ТЧ и соответственно документ печатается с незаполненными до нижнего края листа строками. Помогите разобраться что не так?
кусок кода где видимо закралась проблема:


...............
Результат = Запрос.Выполнить();

Если  НЕ Результат.Пустой() Тогда
Выборка = Результат.Выбрать();

Пока Выборка.Следующий() Цикл
ОбластьСтрокаВторойТаблицы.Параметры.НаименованиеМатериальныхСредств = Выборка.Номенклатура;
ОбластьСтрокаВторойТаблицы.Параметры.Инвентарный = Выборка.ИнвентарныйНомер;
ОбластьСтрокаВторойТаблицы.Параметры.КодОКЕИ = Выборка.КодОКЕИ;
ОбластьСтрокаВторойТаблицы.Параметры.ЕдИзмерения = Выборка.ЕдИзмерения;
ОбластьСтрокаВторойТаблицы.Параметры.Количество = Выборка.Количество;
ОбластьСтрокаВторойТаблицы.Параметры.Цена = Выборка.Цена;
ОбластьСтрокаВторойТаблицы.Параметры.Сумма = Выборка.Сумма;


// Перед тем как вывести область, проверим, умещается ли область (ОбластьСтрокаВторойТаблицы) на страницу
Если Не ТабДок.ПроверитьВывод(ОбластьСтрокаВторойТаблицы)
Тогда 
ТабДок.ВывестиГоризонтальныйРазделительСтраниц (); // создадим новую страницу
ТабДок.Вывести (ОбластьШапкаВторойТаблицы); // выведем шапку второй таблицы
КонецЕсли;

ТабДок.Вывести (ОбластьСтрокаВторойТаблицы);
КонецЦикла;

КонецЕсли;


LexaK

очень похоже что размер печатного листа задан другой, проверьте
ТабДок.РазмерСтраницы - ?
должен быть А4
и ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;//наерно
ответ Понравился? (в смысле пригодился?)

Алексей_1985_06

Цитата: LexaK от 24 мая 2021, 10:33
очень похоже что размер печатного листа задан другой, проверьте
ТабДок.РазмерСтраницы - ?
должен быть А4
и ТабДок.ОриентацияСтраницы = ОриентацияСтраницы.Ландшафт;//наерно

LexaK добрый день! Спасибо что откликнулись..... действительно помогло при добавлении: ТабДок.РазмерСтраницы = "A4";
Спасибо Вам большое!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск