Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2021, 09:33

Как выводить доп.сведения в поле комментарий

Автор ДжангоОсвобожденный, 21 мая 2021, 13:11

0 Пользователей и 1 гость просматривают эту тему.

ДжангоОсвобожденный

Добрый день пользователи форума.
У меня такой вопрос - как научиться выводить дополнительные сведения в поле комментарий, когда создается заказ клиента при выгрузке с сайта на Битриксе
Я уже научился присылать в 1С нужные сведения осталось понять как их внедрять в поле комментарий

Дайте пожалуйста подсказку где и по каким запросам искать, я не могу сформулировать мысль, мой попытки не увенчались успехом. спасибо
Картинку прикрепляю

Так же картинка в виде ссылки на imgBB _https://ibb.co/9rqWSyL

LexaK

не уверен какие у вас есть служебные процедуры для получения значений доп.свойств
но вот пример с запросом
--в конфигураторе, откройте форму документа ЗаказКлиента
--найдите процедуру: ПриСозданииНаСервере
--в нее добавьте такой код

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
...
лкЗапрос = Новый Запрос;
лкЗапрос.Текст = "
    |Выбрать
| Рег.Значение
|из РегистрСведений.ДополнительныеСведения КАК Рег
|Где Рег.Объект = &Ссылка
Рег.Свойство.Наименование = &ИмяСвойства
|";

лкИмяСвойства = "Комментарии покупателя";  //или как там у вас точно называется
лкЗапрос.УстановитьПараметр("Ссылка",Объект.Ссылка);
лкЗапрос.УстановитьПараметр("ИмяСвойства",лкИмяСвойства);
лкВыборка = лкЗапрос.Выполнить().Выбрать();

Если лкВыборка.Следующий() Тогда
лкТекст = лкИмяСвойства + ": " + лкВыборка.Значение;
//почему именно в коммент добавлять? я бы добавил надпись на форме, и выводил в нее
Если СтрНайти(Объект.Комментарий, лкТекст) = 0 Тогда
Объект.Комментарий = Объект.Комментарий + Символы.ПС + лкТекст;
КонецЕсли;
КонецЕсли;



КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

73591

Ответов: 1
Просмотров: 354

75196

Ответов: 15
Просмотров: 1838

Рейтинг@Mail.ru Rambler's Top100

Поиск