Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 авг 2021, 20:52

Запись данных в Excel

Автор neek666, 21 мая 2021, 10:13

0 Пользователей и 1 гость просматривают эту тему.

neek666

Добрый день! Подскажите, где я туплю:

Процедура Выгрузить(Команда)
   ТабДок = Новый ТабличныйДокумент;
   Если ПроверитьЗаполненостьНачальныхДанных() тогда
      СформироватьДанныеДляЗаписиВФайл(ТабДок);//Заполняю табличный документ необходимыми данными
      ПОПЫТКА
         ТабДок.Показать();//здесь вывожу на экран те данные, которые надо записать в файл.
         ЗаписатьДанныеВФайл(ТабДок);
      ИСКЛЮЧЕНИЕ
         Сообщить(ОписаниеОшибки());
      КОНЕЦПОПЫТКИ;
   Иначе
      Сообщить("Заполнены не все реквизиты")
   КонецЕсли;
КонецПроцедуры
Процедура ЗаписатьДанныеВФайл(ТабДок)
    ТабДок.Записать(Объект.ПутьКФайлу, ТипФайлаТабличногоДокумента.XLS);//записываю данные в файл.
КонецПроцедуры


Смысл в чем. Никаких ошибок не происходит. На экран выводятся данные верно, те, которые надо. Но файл чистый. В чем  может быть проблема?
Путь к файлу выводится на форму документа. Он тоже верный. Ошибок типа нет доступа и прочей ереси не выходит. ВООБЩЕ НИКАКИХ ОШИБОК НЕТ. ПОЧЕМУ ФАЙЛ В ИТОГЕ ЧИСТЫЙ? Не меняется даже реквизит файла "Дата изменения". Т.е. складывается такое ощущение, что программа ВООБЩЕ к нему не обращается.


Если пробую тоже самое делать но через "Эксель = Новый COMОбъект("Excel.Application") ;" результат тот же. Без ошибок данными заполняется, но в итоге получается чистый файл.


РАЗОБРАЛСЯ В ПРОБЛЕМЕ.
Запись в файл должна проходить в процедуре (функции) &НаКлиенте!!!
Тема закрыта.

Теги: excel 

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск