Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2021, 09:14

Автоматическое заполнение реквизитов из справочника в документ

Автор KATERINA 861, 14 мая 2021, 03:01

0 Пользователей и 1 гость просматривают эту тему.

KATERINA 861

Здравствуйте,есть справочник "книги" с такими реквизитами как: наименование,автор, жанр и тд. А ещё есть документ "выдача книг". Необходимо, чтобы из справочника "книги",заполнялись автоматически данные,такие как: инвентарный номер, наименование, автор и жанр в документ с помощью программного кода в модуле. Помогите, пожалуйста 🙏🙏🙏

alexandr_ll

Цитата: KATERINA 861 от 14 мая 2021, 03:01
Здравствуйте,есть справочник "книги" с такими реквизитами как: наименование,автор, жанр и тд. А ещё есть документ "выдача книг". Необходимо, чтобы из справочника "книги",заполнялись автоматически данные,такие как: инвентарный номер, наименование, автор и жанр в документ с помощью программного кода в модуле. Помогите, пожалуйста 🙏🙏🙏
Какое приложение - управляемое или обычное? http://forum-1c.ru/index.php?topic=47091.0

KATERINA 861


KATERINA 861

Цитата: alexandr_ll от 14 мая 2021, 06:36
Цитата: KATERINA 861 от 14 мая 2021, 03:01
Здравствуйте,есть справочник "книги" с такими реквизитами как: наименование,автор, жанр и тд. А ещё есть документ "выдача книг". Необходимо, чтобы из справочника "книги",заполнялись автоматически данные,такие как: инвентарный номер, наименование, автор и жанр в документ с помощью программного кода в модуле. Помогите, пожалуйста 🙏🙏🙏
Какое приложение - управляемое или обычное? http://forum-1c.ru/index.php?topic=47091.0
Управляемое, 1С 8.3

Ивашка

Цитата: KATERINA 861 от 14 мая 2021, 03:01
Здравствуйте,есть справочник "книги" с такими реквизитами как: наименование,автор, жанр и тд. А ещё есть документ "выдача книг". Необходимо, чтобы из справочника "книги",заполнялись автоматически данные,такие как: инвентарный номер, наименование, автор и жанр в документ с помощью программного кода в модуле. Помогите, пожалуйста 🙏🙏🙏
делай по образцу
Процедура ПереченьНоменклатурыНаименованиеПриИзменении(Элемент)
    СтрокаТЧ = Элементы.ПереченьНоменклатуры.ТекущиеДанные;
    РеквизитыОбъекта = ПолучитьРеквизитыОбъекта(СтрокаТЧ.Наименование, Новый Структура("Цена, ЕдиницыИзмерения"));
    СтрокаТЧ.Цена = РеквизитыОбъекта.Цена;
    СтрокаТЧ.ЕдиницыИзмерения = РеквизитыОбъекта.ЕдиницыИзмерения; 
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьРеквизит(Ссылка, ИмяРеквизита)
    Возврат Ссылка[ИмяРеквизита];
КонецФункции

&НаСервереБезКонтекста
Функция ПолучитьРеквизитыОбъекта(Объект, знач Реквизиты);
   Для Каждого КлЗнч Из Реквизиты Цикл
        Реквизиты.Вставить(КлЗнч.Ключ, Объект[КлЗнч.Ключ]);
   КонецЦикла;
   Возврат Реквизиты;
КонецФункции

antoneus

Хранить все эти данные в документе абсолютно нет смысла, достаточно того, что в нем хранится ссылка на книгу. Если же все эти данные нужно отображать на форме документа в информационных целях, то это делается так: в форме документа раскрываете узел Объект, раскрываете узел Книга и мышкой перетаскиваете на форму нужные реквизиты. При выборе книги они автоматически заполняются, и все это без единой строчки программного кода в модуле.

KATERINA 861

Цитата: antoneus от 17 мая 2021, 22:52
Хранить все эти данные в документе абсолютно нет смысла, достаточно того, что в нем хранится ссылка на книгу. Если же все эти данные нужно отображать на форме документа в информационных целях, то это делается так: в форме документа раскрываете узел Объект, раскрываете узел Книга и мышкой перетаскиваете на форму нужные реквизиты. При выборе книги они автоматически заполняются, и все это без единой строчки программного кода в модуле.
Спасибо ☺️☺️☺️☺️

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск