Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
18 Дек 2017, 02:35
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: получить полное имя .ТекущийПользователь в 8.2 управляемое приложение тонкий кл  (Прочитано 10258 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
Доброе утро.
вот пытаюсь разобраться как всёже получить имя текущего пользователя
весь инет перерыл ничего не помогает, писал вот так в модуле формы документа

&НаСервере 
Функция ПолучитьПользователя()
        Перем ВыбПользователь;
        ВыбПользователь = ПользователиИнформационнойБазы.ТекущийПользователь().ПолноеИмя;
        Возврат ВыбПользователь;
КонецФункции



&НаКлиенте
Процедура ПриОткрытии(Отказ)
           ......
аааа = ПолучитьПользователя();
           ......
выдает ошибку переменная не определена(ПолучитьПользователя)


затем пытался через экспорт функции прописывать это в общем модуле с галочками в поле "сервер" и "вызов сервера"
тоже не проходит... может кто сталкивался, как решить проблему?


Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
"<span style="white-space: pre;">    </span>" лишнее этого нет )

Оффлайн DeSjeT

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2010-10-11
  • Сайт: 
  • Профессия: Программист 8.1
ПользователиИнформационнойБазы.ТекущийПользователь().Имя

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1

Оффлайн DeSjeT

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2010-10-11
  • Сайт: 
  • Профессия: Программист 8.1
Блин, я сообщение не дописал и отправил, не понял как его удалить...
В общем нужно создать функцию:
&НаСервере
Функция ТекПольз()

Возврат ПользователиИнформационнойБазы.ТекущийПользователь().Имя;

КонецФункции;

Потом её можно вызвать в коде в любом удобном месте:
ТекПоль = ТекПольз(); //Вызов нашей функции
Сообщить(ТекПоль);

П.С. Функцию опиши лучше в самом низу кода

Оффлайн DeSjeT

  • *
  • Сообщений: 22
  • РЕПУТАЦИЯ: 1
  • КПД: 5%
  • Регистрация: 2010-10-11
  • Сайт: 
  • Профессия: Программист 8.1
Как ужасно вставился код функции, вот нормально:
&НаСервере
Функция ТекПольз()

     Возврат ПользователиИнформационнойБазы.ТекущийПользователь().Имя;

КонецФункции;

Оффлайн ldmitriy

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-03-16
  • Сайт: 
  • Профессия: Программист 8.1
да всё заработало, было написано впринципе тоже самое)) это просто я видимо ещё не проснулся) спс


Теги:
 

Получить номер недели в месяце в запросе [номер недели]

Автор MuI_I_IkaРаздел Алгоритмы

Ответов: 0
Просмотров: 4154
Последний ответ 15 Июл 2015, 18:24
от MuI_I_Ika
как получить значение реквизита "Код" в обработке "ПодборНоменклатуры" в УТ10.3

Автор JalibРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1093
Последний ответ 02 Дек 2016, 12:58
от Jalib
Получить полный HTTP код с сервера, Именно полный!

Автор Shining ninjaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2155
Последний ответ 12 Авг 2011, 15:23
от Shining ninja
Как получить значения элементов формы "ПриИзменении"?

Автор OptyРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 7
Просмотров: 8012
Последний ответ 07 Май 2015, 14:38
от Opty
Как получить цену товара контрагента и количество реализованного товара

Автор kbukaРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1639
Последний ответ 08 Сен 2015, 15:46
от Klyacksa

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
133 Сообщений
ilyay ilyay
63 Сообщений
AIFrame
61 Сообщений
alex0402
50 Сообщений
andron81_81
44 Сообщений
oleg-x
41 Сообщений
MuI_I_Ika MuI_I_Ika
31 Сообщений
BuhRust
30 Сообщений
Golickoff Golickoff
27 Сообщений
alexandr_ll
23 Сообщений

* Кто онлайн

  • Точка Гостей: 155
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal