Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 авг 2021, 20:45

Ввод на основании программно?

Автор Анна_Ann, 11 мая 2021, 13:01

0 Пользователей и 1 гость просматривают эту тему.

Анна_Ann

Здравствуйте! Как создать через внешнюю обработку программно ввод на основании?  К примеру из счет на оплату в реализацию тмз? Благодарю!

Ивашка

Цитата: Анна_Ann от 11 мая 2021, 13:01
Здравствуйте! Как создать через внешнюю обработку программно ввод на основании?  К примеру из счет на оплату в реализацию тмз? Благодарю!
Вы это имели ввиду? Если нет, то объясните почетче

Анна_Ann

Здравствуйте. Спасибо , задача решена

Если вдруг кому-нибудь пригодится

Процедура КнопкаВыполнитьНажатие(Кнопка)

ДокОбъект = Документы.РеализацияТоваровУслуг.СоздатьДокумент();

///реквизитфч
    ДокОбъект.Дата = ТекущаяДата();
ДокОбъект.Автор = СчетНаОплату.Автор;
ДокОбъект.АдресДоставки = СчетНаОплату.АдресДоставки;
ДокОбъект.ДоговорКонтрагента = СчетНаОплату.ДоговорКонтрагента;
ДокОбъект.Контрагент = СчетНаоплату.Контрагент;
ДокОбъект.Организация = СчетНаОплату.Организация;
ДокОбъект.Склад = СчетНаОплату.Склад;
ДокОбъект.Ответственный = СчетНаОплату.Ответственный;
///запол тч
Для Каждого СтрокаТЧ Из СчетНаОплату.Товары Цикл

НоваяСтрока = ДокОбъект.Товары.Добавить();
НоваяСтрока.Номенклатура = СтрокаТЧ.Номенклатура;
НоваяСтрока.Количество = СтрокаТЧ.Количество;
НоваяСтрока.Цена = СтрокаТЧ.Цена;
НоваяСтрока.Сумма = СтрокаТЧ.Сумма;

КонецЦикла;

ДокОбъект.Записать();

КонецПроцедуры

nvj84

Можно даже немного уменьшить код

Процедура КнопкаВыполнитьНажатие(Кнопка)
ДокОбъект = Документы.РеализацияТоваровУслуг.СоздатьДокумент();   
///реквизитфч
ЗаполнитьЗначенияСвойств(ДокОбъект, СчетНаОплату, , "Дата")
ДокОбъект.Дата = ТекущаяДата();
///запол тч
Для Каждого СтрокаТЧ Из СчетНаОплату.Товары Цикл
НоваяСтрока = ДокОбъект.Товары.Добавить();
ЗаполнитьЗначенияСвойств(НоваяСтрока, СтрокаТЧ)
КонецЦикла;
ДокОбъект.Записать();
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск