Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
05 авг 2021, 20:39

ВПР для БГУ 2.0

Автор Таня Куталова, 29 апр 2021, 10:48

0 Пользователей и 1 гость просматривают эту тему.

Таня Куталова

Добрый день, подскажите пожалуйста, как правильно взять адрес контрагента и прописать.
БГу 2.0 для ВПФ
Брала из общего модуля УправлениеКонтактнойИнформацией, бестолку, ошибок не выдает но  не выводит в печатную форму. Тапками не кидайтесь, первый     раз такое делаюПроцедура ПечатьАктаВыполненныхУслуг(ТабДокумент, Выборка, Дата) Экспорт
Макет = ПолучитьМакет("АктПриемаПередачи_Новая");
ТабДокумент.КлючПараметровПечати = "ПараметрыПечати_АктПриемаПередачи_Новая";

//ОбластьМакетаШапка  = Макет.ПолучитьОбласть("Шапка");
ОбластьМакетаСтрока = Макет.ПолучитьОбласть("Строка");

ОбластьМакетаСтрока.Параметры.Заполнить(Выборка);


    номер = выборка.пНомер;
Контрагент = Выборка.Контраг;
    ОбластьД=ОбластьМакетаСтрока;
ФактАдрес = УправлениеКонтактнойИнформацией.ПредставлениеКонтактнойИнформацииОбъекта(Контрагент, Справочники.ВидыКонтактнойИнформации.ЮрАдресКонтрагента);
ОбластьД.Параметры.ФактАдресКонтрагента = ФактАдрес;
   //Число прописью
СуммаЧисло = Выборка.СуммаПоДокументу;
//СуммаПропись = ЧислоПрописью(СуммаЧисло, "Л=ru_RU; ДП=Ложь",") рубль,) рубля,) рублей, м, копейка, копейки, копеек, ж, 2");
СуммаПропись=ЧислоПрописью(СуммаЧисло,"Л=ru_RU;ДП=Ложь",") рубль,) рубля,) рублей,м,копейка,копейки,копеек,ж,2");
СуммаПропись=СтрЗаменить(СуммаПропись, " )", ")");
СуммаЧисло = СтрЗаменить(СуммаЧисло,"","");

//СуммаЧисло=СтрЗаменить(СуммаЧисло,"","")") » «, «»);
ОбластьД.Параметры.СуммаЧисло = Цел(СуммаЧисло);
ОбластьД.Параметры.СуммаПропись = СуммаПропись;


  // Договор в падеже
Дог = Выборка.ДоговорВПадеже;
    ДогП =  ПадежП(СокрЛП(Дог), 5,);

//ОбластьД.Параметры.ДоговорВПадеже =ТРег(ДогП);
Договор = ТРег(ДогП);
//ОбластьД.Параметры.ДоговорВПадеже =ТРег(ДогП);
ДогП = СтрЗаменить(Договор,"От", "от");
ОбластьД.Параметры.ДоговорВПадеже = ДогП;
ТабДокумент.Вывести(ОбластьД);

КонецПроцедуры
Функция ПредставлениеКонтактнойИнформацииОбъекта(Контрагент, ВидКонтактнойИнформации, Разделитель = ",", Дата = Неопределено, ДополнительныеПараметры = Неопределено) Экспорт

ТолькоПервая = Ложь;
БезПробелов = Ложь;
Если ТипЗнч(ДополнительныеПараметры) = Тип("Структура") Тогда
Если ДополнительныеПараметры.Свойство("ТолькоПервая") Тогда
ТолькоПервая = ДополнительныеПараметры.ТолькоПервая;
КонецЕсли;
Если ДополнительныеПараметры.Свойство("БезПробелов") Тогда
БезПробелов = ДополнительныеПараметры.БезПробелов;
КонецЕсли;
КонецЕсли;
РазделительВПредставлении = ?(БезПробелов, Разделитель, Разделитель + " ");

ПервыйПроход         = Истина;
КонтактнаяИнформация = ПредставлениеКонтактнойИнформацииОбъекта(Контрагент, "","","");

Если ТипЗнч(КонтактнаяИнформация) = Тип("ТаблицаЗначений") Тогда

Для каждого ЗаписьКонтактнойИнформации Из КонтактнаяИнформация Цикл
Если ПервыйПроход Тогда
Представление = ЗаписьКонтактнойИнформации.Представление;
Если ТолькоПервая Тогда
Возврат Представление;
КонецЕсли;
ПервыйПроход = Ложь;
Иначе
Представление = Представление + РазделительВПредставлении + ЗаписьКонтактнойИнформации.Представление;
КонецЕсли;
КонецЦикла;

Иначе

Представление = КонтактнаяИнформация;

КонецЕсли;

Возврат Представление;

КонецФункции

Теги:
Рейтинг@Mail.ru Rambler's Top100

Поиск