Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 00:16

Как в 8.3 ввести число немодально?

Автор ToryFree, 24 апр 2021, 19:22

0 Пользователей и 1 гость просматривают эту тему.

ToryFree

Нужно проделать в процедуре НаКлиенте некоторые действия, потом интерактивно ввести число размерностью 15.2, потом проделывать следующую порцию действий с его использованием.
Прочла, что это делается через Оповещение с дроблением действий на процедуры до и после, причем частью они будут НаКлиенте, частью НаСервере.
Последняя проба:
&НаКлиенте
Процедура ВнесениеДенег()
СуммаДокумента = 0;
Оповещение = Новый ОписаниеОповещения("СоздатьДокНаНужнуюСумму", СуммаДокумента);
        ПоказатьВводЧисла(Оповещение,СуммаДокумента,"Сумма внесения:",15,2); 
КонецПроцедуры

&НаКлиенте
Процедура СоздатьДокНаНужнуюСумму(СуммаДокумента) Экспорт
Если СуммаДокумента = Неопределено Тогда
    Сообщить("Сумма не введена.");
            Возврат;
КонецЕсли;
СоздатьДок("Текст комментария", СуммаДокумента);
КонецПроцедуры

&НаСервере
Процедура СоздатьДок(Комм, СуммаДокумента)
    //Запрос, создание документа с реквизитом СуммаДокумента
КонецПроцедуры


Итог:
{Обработка.РМКУправляемыйРежим.Форма.Форма.Форма(3608)}: Ошибка при вызове конструктора (ОписаниеОповещения)
   Оповещение = Новый ОписаниеОповещения("СоздатьДокНаНужнуюСумму", СуммаДокумента);
по причине:
Несоответствие типов (параметр номер '2')


Как исправить код?
Заранее большое спасибо!))

antoneus

Оповещение = Новый ОписаниеОповещения("СоздатьДокНаНужнуюСумму", ЭтотОбъект);

Читайте справку внимательнее.

ToryFree

Спасибо за первую подсказку! Прочла справку внимательней, внесла исправления, все получилось!) Спасибо!)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск