Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 15:36

Не выводиться результат запроса

Автор MiThO, 12 апр 2021, 12:20

0 Пользователей и 1 гость просматривают эту тему.

MiThO

&НаКлиенте
Процедура ТерминалПоФирме(Команда)
   ТабДок=Новый ТабличныйДокумент;
   ПечатьВДокументе3(ТабДок);
   ТабДок.ОтображатьСетку=Ложь;
   ТабДок.Защита=Ложь;
   ТабДок.ТолькоПросмотр=Ложь;
   ТабДок.ОтображатьЗаголовки=Ложь;
   ТабДок.Показать();
КонецПроцедуры

&НаСервере
Процедура ПечатьВДокументе3(ТабДок)
Макет=Документы.ТерминалыВКабинете.ПолучитьМакет("Макет");
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ Терминал КАК Терминал,ЗаводскойНомер,СерийныйНомер,Фирма,
|ОтдалЭкспедитор,Неисправность,РабочееСостояние,ДатаПоступление
|ИЗ Документ.ТерминалыВКабинете       
|ГДЕ Фирма =&Фи";
Запрос.УстановитьПараметр("Фи", ИП);
Рез=Запрос.Выполнить().Выбрать();
ТабДок.Очистить();
Шапка=Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока=Макет.ПолучитьОбласть("Строка");
ТабДок.Вывести(Шапка);
Пока Рез.Следующий()>0 Цикл
   ОбластьСтрока.Параметры.Заполнить(Рез);
   Табдок.Вывести(ОбластьСтрока);
   КонецЦикла;
КонецПроцедуры

Сам запрос работает, но как только добавляю параметр,ничего не выводиться,сообщения об ошибке тоже нету. Кто нибудь подскажите в чём может быть проблема?

pavl_vs

MiThO, а где определен параметр ИП?

MiThO

Цитата: pavl_vs от 12 апр 2021, 12:32
MiThO, а где определен параметр ИП?
в форме списка документа где и делается запрос. Сам реквизит создан внутри формы
Добавлено: 12 апр 2021, 13:36


Проблема решилась. Надо было Реквизит "Фирма" было сделать ссылкой,а не строкой и тогда всё работает. Сразу отвечу на вопрос почему реквезит был строкой, был написан код для автоматического заполнения.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск