Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 01:19

Вывести итог в печатной форме

Автор MiThO, 09 апр 2021, 08:01

0 Пользователей и 1 гость просматривают эту тему.

MiThO

&НаКлиенте
   Процедура ПечатьТерминалов(Команда)
      ТабДок=Новый ТабличныйДокумент;
   ПечатьВДокументе(ТабДок);
   ТабДок.ОтображатьСетку=Ложь;
   ТабДок.Защита=Ложь;
   ТабДок.ТолькоПросмотр=Ложь;
   ТабДок.ОтображатьЗаголовки=Ложь;
   ТабДок.Показать();
КонецПроцедуры

&НаСервере
Процедура ПечатьВДокументе(ТабДок)
Макет=Документы.ТерминалыВКабинете.ПолучитьМакет("Макет");
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ Терминал КАК Терминал,ЗаводскойНомер,СерийныйНомер,ОтдалЭкспедитор,Неисправность,РабочееСостояние,ДатаПоступление
|ИЗ Документ.ТерминалыВКабинете
|УПОРЯДОЧИТЬ ПО Терминал УБЫВ";
Рез=Запрос.Выполнить().Выбрать();
ТабДок.Очистить();
Шапка=Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока=Макет.ПолучитьОбласть("Строка");
ТабДок.Вывести(Шапка);
Пока Рез.Следующий()>0 Цикл
   ОбластьСтрока.Параметры.Заполнить(Рез);
   Табдок.Вывести(ОбластьСтрока);
   КонецЦикла;
КонецПроцедуры



Надо вывести количество позиций в печатной форме. Хелпаните,а то додуматься не могу что писать,заранее спасибо.

alexandr_ll

Цитата: MiThO от 09 апр 2021, 08:01
&НаКлиенте
   Процедура ПечатьТерминалов(Команда)
      ТабДок=Новый ТабличныйДокумент;
   ПечатьВДокументе(ТабДок);
   ТабДок.ОтображатьСетку=Ложь;
   ТабДок.Защита=Ложь;
   ТабДок.ТолькоПросмотр=Ложь;
   ТабДок.ОтображатьЗаголовки=Ложь;
   ТабДок.Показать();
КонецПроцедуры

&НаСервере
Процедура ПечатьВДокументе(ТабДок)
Макет=Документы.ТерминалыВКабинете.ПолучитьМакет("Макет");
Запрос=Новый Запрос;
Запрос.Текст="ВЫБРАТЬ Терминал КАК Терминал,ЗаводскойНомер,СерийныйНомер,ОтдалЭкспедитор,Неисправность,РабочееСостояние,ДатаПоступление
|ИЗ Документ.ТерминалыВКабинете
|УПОРЯДОЧИТЬ ПО Терминал УБЫВ";
Рез=Запрос.Выполнить().Выбрать();
ТабДок.Очистить();
Шапка=Макет.ПолучитьОбласть("Шапка");
ОбластьСтрока=Макет.ПолучитьОбласть("Строка");
ТабДок.Вывести(Шапка);
Пока Рез.Следующий()>0 Цикл
   ОбластьСтрока.Параметры.Заполнить(Рез);
   Табдок.Вывести(ОбластьСтрока);
   КонецЦикла;
КонецПроцедуры



Надо вывести количество позиций в печатной форме. Хелпаните,а то додуматься не могу что писать,заранее спасибо.
Ну например, создать переменную и в цикле ее увеличивать на 1.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск