Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2021, 18:13
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Установка значения выделенных строк  (Прочитано 60 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ивашка

  • *
  • Сообщений: 49
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-08-27
  • Сайт: 
  • Профессия: Ученик 1С
Приветствую!!! Есть документ ПланированиеВыработкиПоРесурсам, реквизиты ТЧ: Сотрудник, Часы, Комментарии, в форме этого документа создал кнопки "Заполнить"(при нажатии загружает в ТЧ сотрудников) и "УстановкаЗначения", эта кнопка устанавливает значения для выделенных строк,т.е я выделяю строки(может быть несколько), должен открываться общая форма(общая форма "ВыборПроизвольногоЗначения", реквизит: Значения, тип: Произвольный, есть кнопки "ПодвердитьВыбор" и "ОтменитьВыбор")
в модуле общей формы:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Элементы.Значение.ОграничениеТипа = Параметры.ОписаниеТипаЗначения;
КонецПроцедуры
 
&НаКлиенте
Процедура ПодтвердитьВыбор(Команда)
    ПараметрЗакрытия = Новый Структура("Значение", Значение);
    ЭтаФорма.Закрыть(ПараметрЗакрытия); 
КонецПроцедуры
 
&НаКлиенте
Процедура ОтменитьВыбор(Команда)
    ЭтаФорма.Закрыть(Неопределено); 
КонецПроцедуры
в модуле формы документа:
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры
 
&НаСервере
Процедура ЗаполнитьНаСервере()
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   ФизическиеЛица.Ссылка КАК Сотрудник
        |ИЗ
        |   Справочник.ФизическиеЛица КАК ФизическиеЛица
        |ГДЕ
        |   НЕ ФизическиеЛица.ПометкаУдаления
        |
        |УПОРЯДОЧИТЬ ПО
        |   Сотрудник";
   
    ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
   
    Пока ВыборкаЗапроса.Следующий() Цикл
        НоваяСтрокаТЧ = Объект.ПланированиеВыработки.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ВыборкаЗапроса);
    КонецЦикла;
   
    ЭтаФорма.Модифицированность = Истина;
   
КонецПроцедуры
 
&НаКлиенте
Процедура ЗаполнитьВВыделенныхСтроках(Команда)
   
    ЭтаФорма.Модифицированность = Истина;
       
    ВыделенныеСтроки = Элементы.ПланированиеВыработки.ВыделенныеСтроки;
    Для Каждого Строка Из ВыделенныеСтроки Цикл
        //ОткрытьФорму("ОбщаяФорма.АИ_ВыборПроизвольногоЗначения");
    КонецЦикла
   
КонецПроцедуры
как обойти выделенные строки и установить значение? помогите?


Теги:
 

ПРоблема с построением табличного значения

Автор Svetik2012Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 5
Просмотров: 2490
Последний ответ 01 Мар 2012, 15:29
от Dethmontt
Как проверить в запросе поле типа Хранилище значения на пустоту

Автор AmAlAlexanderРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 10938
Последний ответ 14 Сен 2013, 01:12
от AmAlAlexander
мутабельные значения с сервера на клиет

Автор VolusРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 297
Последний ответ 13 Фев 2020, 19:19
от Volus
Управляемая форма. Возврат выбранного значения

Автор АльбинаННРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1345
Последний ответ 16 Дек 2016, 00:14
от АльбинаНН
Как вывести значения ячеек тз согласно условиям в соответствующие ячейки в макете

Автор katodРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 1204
Последний ответ 07 Апр 2017, 09:24
от alex0402

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
76 Сообщений
LexaK
31 Сообщений
DmitriyF DmitriyF
11 Сообщений
alexandr_ll
10 Сообщений
Татьяна Шлотгауэр Татьяна Шлотгауэр
10 Сообщений
Мария2021
9 Сообщений
slimuz
8 Сообщений
zorro777
8 Сообщений
margo
7 Сообщений
Funt Фунтиков
6 Сообщений

* Кто онлайн

  • Точка Гостей: 376
  • Точка Скрытых: 0
  • Точка Пользователей: 5
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal