Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 дек 2021, 07:27

Установка значения выделенных строк

Автор Ивашка, 08 апр 2021, 15:54

0 Пользователей и 1 гость просматривают эту тему.

Ивашка

Приветствую!!! Есть документ ПланированиеВыработкиПоРесурсам, реквизиты ТЧ: Сотрудник, Часы, Комментарии, в форме этого документа создал кнопки "Заполнить"(при нажатии загружает в ТЧ сотрудников) и "УстановкаЗначения", эта кнопка устанавливает значения для выделенных строк,т.е я выделяю строки(может быть несколько), должен открываться общая форма(общая форма "ВыборПроизвольногоЗначения", реквизит: Значения, тип: Произвольный, есть кнопки "ПодвердитьВыбор" и "ОтменитьВыбор")
в модуле общей формы:
&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
    Элементы.Значение.ОграничениеТипа = Параметры.ОписаниеТипаЗначения;
КонецПроцедуры

&НаКлиенте
Процедура ПодтвердитьВыбор(Команда)
    ПараметрЗакрытия = Новый Структура("Значение", Значение);
    ЭтаФорма.Закрыть(ПараметрЗакрытия); 
КонецПроцедуры

&НаКлиенте
Процедура ОтменитьВыбор(Команда)
    ЭтаФорма.Закрыть(Неопределено); 
КонецПроцедуры

в модуле формы документа:
&НаКлиенте
Процедура Заполнить(Команда)
    ЗаполнитьНаСервере();
КонецПроцедуры

&НаСервере
Процедура ЗаполнитьНаСервере()
   
    Запрос = Новый Запрос;
    Запрос.Текст =
        "ВЫБРАТЬ
        |   ФизическиеЛица.Ссылка КАК Сотрудник
        |ИЗ
        |   Справочник.ФизическиеЛица КАК ФизическиеЛица
        |ГДЕ
        |   НЕ ФизическиеЛица.ПометкаУдаления
        |
        |УПОРЯДОЧИТЬ ПО
        |   Сотрудник";
   
    ВыборкаЗапроса = Запрос.Выполнить().Выбрать();
   
    Пока ВыборкаЗапроса.Следующий() Цикл
        НоваяСтрокаТЧ = Объект.ПланированиеВыработки.Добавить();
        ЗаполнитьЗначенияСвойств(НоваяСтрокаТЧ,ВыборкаЗапроса);
    КонецЦикла;
   
    ЭтаФорма.Модифицированность = Истина;
   
КонецПроцедуры

&НаКлиенте
Процедура ЗаполнитьВВыделенныхСтроках(Команда)
   
    ЭтаФорма.Модифицированность = Истина;
       
    ВыделенныеСтроки = Элементы.ПланированиеВыработки.ВыделенныеСтроки;
    Для Каждого Строка Из ВыделенныеСтроки Цикл
        //ОткрытьФорму("ОбщаяФорма.АИ_ВыборПроизвольногоЗначения");
    КонецЦикла
   
КонецПроцедуры

как обойти выделенные строки и установить значение? помогите?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск