Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
23 Апр 2021, 17:52
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Изменение документа в процесса выполнения бизнес процесса  (Прочитано 102 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн kapibarich2000

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2021-03-29
  • Сайт: 
  • Профессия: Ученик 1С
Доброе время суток, товарищи!
    Я столкнулся с проблемой изменения документа.
    Имеется документ с табличной частью. Когда производится запись создается бизнес процесс, хранящий ссылку на запись в документе. Возникает ситуация, при которой необходимо изменить табличную часть в документе.
    Для начала, я попытался просто попробовать изменить количество 1го товара в табличной части документа, но после выполнения кода ничего не происходит. Просматривал работу кода с помощью отладки и (shift+f9) - все изменяется в отладчике. Но после всех телодвижений табличная часть документа так и не изменилась. Подскажите, пожалуйста, в чем ошибка?

&НаСервере
Процедура ИзменениеСоставаПоставки()

  Если Объект.СсылкаДокументаПоставки.Пустая() Тогда
  Сообщить("Ссылка на документ не найдена");
  КонецЕсли;
 
  ДокументПоставки=Объект.СсылкаДокументаПоставки.ПолучитьОбъект();
   
  ТаблицаПоставкиИзДокумента=ДокументПоставки.Товары.Выгрузить();
 
  Для Каждого СтрДанныхПоставкиИзДокумента Из ТаблицаПоставкиИзДокумента Цикл
СтрДанныхПоставкиИзДокумента.Количество=77; 
Прервать; 
  КонецЦикла;
  ДокументПоставки.Записать(РежимЗаписиДокумента.Запись);


Оффлайн LexaK

  • *****
  • Сообщений: 2481
  • РЕПУТАЦИЯ: 779
  • КПД: 31%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
не надо выгружать ТЧ.Товары в ТЗ, это у вас копия получается
попробуйте так
&НаСервере
Процедура ИзменениеСоставаПоставки()

      Если Объект.СсылкаДокументаПоставки.Пустая() Тогда
          Сообщить("Ссылка на документ не найдена");
      КонецЕсли;
     
      ДокументПоставки=Объект.СсылкаДокументаПоставки.ПолучитьОбъект();
       
      //ТаблицаПоставкиИзДокумента=ДокументПоставки.Товары.Выгрузить();
 
      //Для Каждого СтрДанныхПоставкиИзДокумента Из ТаблицаПоставкиИзДокумента Цикл
      Для Каждого СтрДанныхПоставкиИзДокумента Из ДокументПоставки.Товары Цикл
            СтрДанныхПоставкиИзДокумента.Количество=77; 
            Прервать; 
          КонецЦикла;
      ДокументПоставки.Записать(РежимЗаписиДокумента.Запись);
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн kapibarich2000

  • *
  • Сообщений: 1
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2021-03-29
  • Сайт: 
  • Профессия: Ученик 1С
LexaK, спасибо большое за помощь! Какая же банальная ошибка у меня была :xfbnsdfb:


Теги:
 

Результат запроса не выгружается в поле табличного документа

Автор DenРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 407
Последний ответ 05 Фев 2020, 11:15
от Den
Заполнение поля печатной формы из реквизита другого документа

Автор mastersРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 4905
Последний ответ 04 Авг 2013, 23:43
от GRADUS
Заполнение данных документа из регистра сведений

Автор Анна АнисимоваРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 758
Последний ответ 01 Июн 2020, 13:18
от LexaK
Вывод на печать Табличную часть документа

Автор Кот_ЛеопольдРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1043
Последний ответ 31 Янв 2019, 08:05
от Кот_Леопольд
Заполнение табличной части документа

Автор AlexKagРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 8604
Последний ответ 21 Сен 2012, 19:43
от AlexKag

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
76 Сообщений
LexaK
31 Сообщений
DmitriyF DmitriyF
11 Сообщений
alexandr_ll
10 Сообщений
Татьяна Шлотгауэр Татьяна Шлотгауэр
10 Сообщений
Мария2021
9 Сообщений
slimuz
8 Сообщений
zorro777
8 Сообщений
margo
7 Сообщений
Dom Doma Dom Doma
6 Сообщений

* Кто онлайн

  • Точка Гостей: 473
  • Точка Скрытых: 0
  • Точка Пользователей: 6
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal