Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 авг 2021, 13:46

Как ссылаться на табличную часть справочника?

Автор flippo, 25 фев 2021, 21:37

0 Пользователей и 1 гость просматривают эту тему.

flippo

Есть реквизит Email в табличной части Доп_данные_о_клиенте справочника Клиенты
При выборе застрахованногоЛица пишет поле объекта не обнаружено (Email) //13 строка как ссылаться на табличную часть ?
Я просто очень тупой понять не могу

&НаКлиенте
Процедура ЗастрахованноеЛицоПриИзменении(Элемент)
   
    Для каждого Строка Из Объект.ТабличнаяЧасть1 Цикл
        Строка.Email = ПолучитьЗначениеРеквизитаСправочникаКлиентыНаСервере(Объект.ЗастрахованноеЛицо);
    КонецЦикла
   
КонецПроцедуры
   
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаСправочникаКлиентыНаСервере(СсылкаНаСправочникКлиенты);
   
    Возврат СсылкаНаСправочникКлиенты.Email; // не могу понять как указать на табличную часть Доп_данные_о_клиенте

КонецФункции

pavl_vs

Цитата: flippo от 25 фев 2021, 21:37
&НаСервереБезКонтекста
Функция ПолучитьЗначениеРеквизитаСправочникаКлиентыНаСервере(СсылкаНаСправочникКлиенты);
   
    Возврат СсылкаНаСправочникКлиенты.Email; // не могу понять как указать на табличную часть Доп_данные_о_клиенте

КонецФункции
[/code]
Нужно указать наименование ТЧ справочника.
Скорее всего так:
    СсылкаНаСправочникКлиенты.НаименованиеТЧ.Email


DNN

Наверно все-таки так:
СсылкаНаСправочникКлиенты.НаименованиеТЧ[0].Email

Это при условии, что Email в первой строке


pavl_vs

Цитата: DNN от 26 фев 2021, 07:17
СсылкаНаСправочникКлиенты.НаименованиеТЧ[0].Email
Это при условии, что Email в первой строке
Наименования Табличных частей имеют конкретное значение (Строка), например, "КонтактнаяИнформация", "Роли", "ДополнительныеРеквизиты" и т.п.
Индекс не применим - будет ошибка.

antoneus

Цитата: pavl_vs от 26 фев 2021, 11:25
Цитата: DNN от 26 фев 2021, 07:17
СсылкаНаСправочникКлиенты.НаименованиеТЧ[0].Email
Это при условии, что Email в первой строке
Наименования Табличных частей имеют конкретное значение (Строка), например, "КонтактнаяИнформация", "Роли", "ДополнительныеРеквизиты" и т.п.
Индекс не применим - будет ошибка.

Какая именно ошибка? То есть, конструкция СсылкаНаСправочникКлиенты.НаименованиеТЧ[0].Email (при условии, что ТЧ по имени "НаименованиеТЧ" есть) - нерабочая?

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск