Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
15 Дек 2017, 16:56
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Срочно нужна помощь при расчете НДС  (Прочитано 7657 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Дело в том, что создаю документ Приходный кассовый ордер на 1С: 8.2 и в табличной части "РасчетныеРеквизиты" необходимо, чтобы после ввода суммы("СуммаПлатежа") и выбора ставки НДС("СтавкаНДС") вычислялась сумма НДС. Ставки НДС берутся из справочника "ВидыСтавокНДС" и имеют три значения: "18%", "18% в сумме", "Без НДС".
При заполнении документа при выборе ставки НДС выходит ошибка "Значение не является значением объектного типа (СтавкаНДС)" и у меня вопрос: при имеющихся данных как присвоить реквизиту "СтавкаНДС" значение объектного типа???



В модуле формы документа у меня такой код:

&НаКлиенте
Процедура РасчетныеРеквизитыСуммаПлатежаПриИзменении(Элемент)
   СтрокаТабличнойЧасти=Элементы.РасчетныеРеквизиты.ТекущаяСтрока;
   РаботаСДокументами.РассчитатьСуммуНДС(СтрокаТабличнойЧасти);

КонецПроцедуры

&НаКлиенте
Процедура РасчетныеРеквизитыСтавкаНДСПриИзменении(Элемент)
   СтрокаТабличнойЧасти=Элементы.РасчетныеРеквизиты.ТекущаяСтрока;
   РаботаСДокументами.РассчитатьСуммуНДС(СтрокаТабличнойЧасти);

КонецПроцедуры

А в общем модуле "РаботаСДокументами" следующая процедура:

Процедура РассчитатьСуммуНДС(СтрокаТабличнойЧасти) Экспорт
   
     Если СтрокаТабличнойЧасти.СтавкаНДС="18%" Тогда СтрокаТабличнойЧасти.СуммаНДС=(СтрокаТабличнойЧасти.СуммаПлатежа*18)/100;
    Если СтрокаТабличнойЧасти.СтавкаНДС="18% в сумме" Тогда СтрокаТабличнойЧасти.СуммаНДС=СтрокаТабличнойЧасти.СуммаПлатежа*1.18;
   КонецЕсли;    
   Иначе СтрокаТабличнойЧасти.СуммаНДС="0";
   КонецЕсли;
                              
КонецПроцедуры         
               
"Только смелость в прохождении пути позволяет пути показать себя!"


Оффлайн cubase

  • *
  • Сообщений: 15
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2010-05-21
  • Сайт: 
  • Профессия: Бухгалтер
если ставка ндс предорпеделенный элемент справочника, то

Если СтрокаТабличнойЧасти.СтавкаНДС= Справочники.СтавкиНДС.18%  Тогда
Только насчет % сомневаюсь - похоже это не допустимый символ xml !

Если не предопределенный

Ставка18 = Справочники.СтавкиНДС.НайтиПоНаименованию("18%");
Если СтрокаТабличнойЧасти.СтавкаНДС= Ставка18  Тогда

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Спасибо, если использовать первый вариант выдает ошибку:  Переменная не определена (Справочники).
Как мне ее "определить"?
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
На клиенте предопределенный элемент справочника можно получить с помощью функции ПредопределенноеЗначение()

Если СтрокаТабличнойЧасти.СтавкаНДС= ПредопределенноеЗначение("Справочник.СтавкиНДС.18Проц")  Тогда
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
теперь выходит ошибка "значение не является значением объектного типа (СтавкаНДС)". Что делать?
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Точку останова и проверяйте чему равна СтрокаТабличнойЧасти
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
извините пожалуйста, а как сделать точку останова?
"Только смелость в прохождении пути позволяет пути показать себя!"

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
F9 на нужной строке, потом запускаем в режиме отладки.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Salima, если Вы будете безпричинно давить кнопку "Сообщить модератору", заработаете только раздражение в свой адрес.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Salima

  • *
  • Сообщений: 26
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-11
  • Сайт: 
  • Профессия: Разработчик 1С
Извините, пожалуйста, я думала так вы быстрее увидите)
"Только смелость в прохождении пути позволяет пути показать себя!"


Теги:
 

Необходима помощь в создании обработки "Внутренний заказ"

Автор miliamРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 5193
Последний ответ 28 Апр 2013, 20:26
от Besart
Нужна ВПФ - дайте рыбу "СчетНаОплатуПокупателю" для 1с 8.2. УТ 10

Автор Anton99Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 3329
Последний ответ 09 Окт 2011, 20:25
от Anton99
Кому нужна инф. по конфе "Конвертация"

Автор ВоронкинРаздел Закрытые темы

Ответов: 2
Просмотров: 3818
Последний ответ 09 Фев 2012, 19:38
от Столяр
Нужна консультация по "Бухгалтерия для Украины", редакция 1.0. Первое событие

Автор nopРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2029
Последний ответ 25 Окт 2010, 15:17
от nop
Перенесено: нужна внешняя обработка для ПКО "Печать квитанции об уплате..."

Автор cska-fanat-kzРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 2290
Последний ответ 10 Фев 2012, 07:45
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
179 Сообщений
ilyay ilyay
69 Сообщений
alex0402
54 Сообщений
oleg-x
48 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
MuI_I_Ika MuI_I_Ika
33 Сообщений
Golickoff Golickoff
31 Сообщений
BuhRust
30 Сообщений
Dima Dddd Dima Dddd
26 Сообщений

* Кто онлайн

  • Точка Гостей: 608
  • Точка Скрытых: 1
  • Точка Пользователей: 13
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal