Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 14:43

Вызов печати из формы обработки

Автор Dmitry Pyshkarev, 24 фев 2021, 11:51

0 Пользователей и 1 гость просматривают эту тему.

Dmitry Pyshkarev

Доброго времени суток.
1С:ERP Управление предприятием 2 для Беларуси (2.4.7.164)
1С:Предприятие 8.3 (8.3.16.1063)

Создана обработка с формой где заполняются данные, как вызвать "красивую" печать?
Модуль формы
&НаКлиенте
Процедура Подключаемый_ВыполнитьКоманду(Команда)
ПодключаемыеКомандыКлиент.ВыполнитьКоманду(ЭтотОбъект, Команда, Элементы.ТаблицаЗначенийОснование);
КонецПроцедуры

&НаСервере
Процедура Подключаемый_ВыполнитьКомандуНаСервере(Контекст, Результат)
ПодключаемыеКоманды.ВыполнитьКоманду(ЭтотОбъект, Контекст, Элементы.ТаблицаЗначенийОснование, Результат);
КонецПроцедуры

&НаКлиенте
Процедура Подключаемый_ОбновитьКоманды()
ПодключаемыеКомандыКлиентСервер.ОбновитьКоманды(ЭтотОбъект, Элементы.ТаблицаЗначенийОснование);
КонецПроцедуры
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды



&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)

ДатаДокумента = ТекущаяДата();
НомерДокумента = "б/н";
Период.ДатаНачала = НачалоДня(ТекущаяДата());
Период.ДатаОкончания = КонецДня(ТекущаяДата());

// СтандартныеПодсистемы.ПодключаемыеКоманды
ПодключаемыеКоманды.ПриСозданииНаСервере(ЭтотОбъект);
// Конец СтандартныеПодсистемы.ПодключаемыеКоманды

СобытияФорм.ПриСозданииНаСервере(ЭтаФорма, Отказ, СтандартнаяОбработка);


КонецПроцедуры


Модуль менеджера
Процедура Печать(МассивОбъектов, ПараметрыПечати, КоллекцияПечатныхФорм, ОбъектыПечати, ПараметрыВывода) Экспорт

Если УправлениеПечатью.НужноПечататьМакет(КоллекцияПечатныхФорм, "КонвертСФПолученный") Тогда
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
КоллекцияПечатныхФорм,
"КонвертСФПолученный",
НСтр("ru = 'Конверт счет-фактура полученный'"),
ауСформироватьКонвертСФ(МассивОбъектов, ОбъектыПечати, ПараметрыПечати));
КонецЕсли;

КонецПроцедуры



// Заполняет список команд печати.
//
// Параметры:
//   КомандыПечати - ТаблицаЗначений - состав полей см. в функции УправлениеПечатью.СоздатьКоллекциюКомандПечати.
//
Процедура ДобавитьКомандыПечати(КомандыПечати) Экспорт

КомандаПечати = КомандыПечати.Добавить();
КомандаПечати.Идентификатор = "ПечатьПустая";
КомандаПечати.МенеджерПечати = "Обработка.ауПечатьСчетФактурыПолученный";
КомандаПечати.Представление = НСтр("ru = 'Пустая печать'");


КонецПроцедуры


Также использую команды на форме для заполнения табличного документа.


&НаСервере
Процедура ПроцедураКнопкиПечать
+++++Заполнение табличного документа
КоллекцияПечатныхФорм = Новый ТаблицаЗначений;
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяВРЕГ");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("Экземпляров");
КоллекцияПечатныхФорм.Колонки.Добавить("СинонимМакета");
КоллекцияПечатныхФорм.Колонки.Добавить("ТабличныйДокумент");
КоллекцияПечатныхФорм.Колонки.Добавить("Картинка");
КоллекцияПечатныхФорм.Колонки.Добавить("ПолныйПутьКМакету");
КоллекцияПечатныхФорм.Колонки.Добавить("ИмяФайлаПечатнойФормы");

        ТекКол = КоллекцияПечатныхФорм.Добавить();
ТекКол.ИмяВРЕГ = Врег("ПФ_MXL_МакетСФ");
ТекКол.ИмяМакета = "ПФ_MXL_МакетСФ";
ТекКол.Экземпляров = 1;

//вывод в печать
УправлениеПечатью.ВывестиТабличныйДокументВКоллекцию(
КоллекцияПечатныхФорм ,
"ПФ_MXL_МакетСФ",
НСтр("ru = 'ЭСФЧ с ошибками'"),
ТабДок);
ТабличныйДокумент = ТабДок;
КонецПроцедуры



Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск