Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
07 Мар 2021, 05:37
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Оптимизация хранения картинок в спарвочнике  (Прочитано 124 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Алексей_1985_06

  • ***
  • Сообщений: 171
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2019-09-01
  • Сайт: 
  • Профессия: Ученик 1С
Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры.
2. Создал справочник "Номенклатура", реквизит "Изображение" - тип ХранилищеЗначения и реквизит формы "АдресКартинки" - тип строка - разместил на форме в виде поля картинки.
3. На просторах нашел такое решение:

&НаКлиенте
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)

Оповещение = Новый ОписаниеОповещения ("АдресКартинкиНажатиеЗавершение", ЭтотОбъект);
НачатьПомещениеФайла(Оповещение,,,Истина,УникальныйИдентификатор);
СтандартнаяОбработка = Ложь;

КонецПроцедуры

&НаКлиенте
Процедура АдресКартинкиНажатиеЗавершение (Результат, Адрес, ПомещаемыйФайл, ДополнительныеПараметры) Экспорт

Если НЕ Результат Тогда
Возврат
 КонецЕсли;
  АдресКартинки = Адрес;
 Модифицированность = Истина;

КонецПроцедуры

&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
ТекущийОбъект.Изображение = Новый ХранилищеЗначения (ПолучитьИзВременногоХранилища(АдресКартинки));
КонецЕсли;
КонецПроцедуры

&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Изображение");
КонецПроцедуры

Но как я понимаю, это не оптимально, т.к. картинка храниться в элементе справочника.
Подскажите как правильно (оптимально) реализовать хранение файлов?



Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 4328
  • РЕПУТАЦИЯ: 173
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Регистрация: 2015-03-12
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры
Одну картинку всей номенклатуры?
Конфигурация - какая?

Оффлайн Алексей_1985_06

  • ***
  • Сообщений: 171
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2019-09-01
  • Сайт: 
  • Профессия: Ученик 1С
Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры
Одну картинку всей номенклатуры?
Конфигурация - какая?

Конфигурация самописная. Каждой номенклатуре (ее много) соответствует только одна картинка (соответственно тоже много картинок).

Оффлайн Геннадий ОбьГЭС

  • Консультант-программист 1С. ЗВОНИТЕ!
  • *****
  • Сообщений: 4328
  • РЕПУТАЦИЯ: 173
  • КПД: 4%
  • Проблемы в 1С решу удаленно дешево
  • Регистрация: 2015-03-12
  • Компания: Фрилансер - частное лицо
  • Профессия: Программист 1С
Т.е. изоретаете велосипед
Обычное или управляемое прилажение?

Откройте типовую К и посм
Там настраивается - где хранить картинки - в базе или на диске

Оффлайн Алексей_1985_06

  • ***
  • Сообщений: 171
  • РЕПУТАЦИЯ: -1
  • Регистрация: 2019-09-01
  • Сайт: 
  • Профессия: Ученик 1С
Т.е. изоретаете велосипед
Обычное или управляемое прилажение?

Откройте типовую К и посм
Там настраивается - где хранить картинки - в базе или на диске

Ну типа того (велосипед)... Приложение управляемое!  К сожалению типовой нет.

Оффлайн ls600

  • ****
  • Сообщений: 365
  • РЕПУТАЦИЯ: 30
  • КПД: 8%
  • Регистрация: 2012-05-14
  • Сайт: 
  • Профессия: Программист 1С
УТ 11.4 Демо
В помощь демо конфигурация


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
104 Сообщений
antoneus antoneus
30 Сообщений
Алексей_1985_06
29 Сообщений
LexaK
27 Сообщений
BuhRust
20 Сообщений
ls600 ls600
17 Сообщений
kah
13 Сообщений
DNN
11 Сообщений
DmitriyF DmitriyF
10 Сообщений
Ивашка
9 Сообщений

* Кто онлайн

  • Точка Гостей: 150
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal