Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 дек 2021, 06:55

Оптимизация хранения картинок в спарвочнике

Автор Алексей_1985_06, 23 фев 2021, 11:34

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры.
2. Создал справочник "Номенклатура", реквизит "Изображение" - тип ХранилищеЗначения и реквизит формы "АдресКартинки" - тип строка - разместил на форме в виде поля картинки.
3. На просторах нашел такое решение:

&НаКлиенте
Процедура АдресКартинкиНажатие(Элемент, СтандартнаяОбработка)

Оповещение = Новый ОписаниеОповещения ("АдресКартинкиНажатиеЗавершение", ЭтотОбъект);
НачатьПомещениеФайла(Оповещение,,,Истина,УникальныйИдентификатор);
СтандартнаяОбработка = Ложь;

КонецПроцедуры


&НаКлиенте
Процедура АдресКартинкиНажатиеЗавершение (Результат, Адрес, ПомещаемыйФайл, ДополнительныеПараметры) Экспорт

Если НЕ Результат Тогда
Возврат
КонецЕсли;
  АдресКартинки = Адрес;
Модифицированность = Истина;

КонецПроцедуры


&НаСервере
Процедура ПередЗаписьюНаСервере(Отказ, ТекущийОбъект, ПараметрыЗаписи)
Если ЭтоАдресВременногоХранилища(АдресКартинки) Тогда
ТекущийОбъект.Изображение = Новый ХранилищеЗначения (ПолучитьИзВременногоХранилища(АдресКартинки));
КонецЕсли;
КонецПроцедуры


&НаСервере
Процедура ПриСозданииНаСервере(Отказ, СтандартнаяОбработка)
АдресКартинки = ПолучитьНавигационнуюСсылку(Объект.Ссылка, "Изображение");
КонецПроцедуры


Но как я понимаю, это не оптимально, т.к. картинка храниться в элементе справочника.
Подскажите как правильно (оптимально) реализовать хранение файлов?


Геннадий ОбьГЭС

Цитата: Алексей_1985_06 от 23 фев 2021, 11:34
Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры
Одну картинку всей номенклатуры?
Конфигурация - какая?

Алексей_1985_06

Цитата: Геннадий ОбьГЭС от 23 фев 2021, 12:22
Цитата: Алексей_1985_06 от 23 фев 2021, 11:34
Уважаемые программисты, прошу Вашей помощи в следующем стандартном вопросе:
1. Необходимо отображать картинку номенклатуры
Одну картинку всей номенклатуры?
Конфигурация - какая?

Конфигурация самописная. Каждой номенклатуре (ее много) соответствует только одна картинка (соответственно тоже много картинок).

Геннадий ОбьГЭС

Т.е. изоретаете велосипед
Обычное или управляемое прилажение?

Откройте типовую К и посм
Там настраивается - где хранить картинки - в базе или на диске

Алексей_1985_06

Цитата: Геннадий ОбьГЭС от 23 фев 2021, 12:51
Т.е. изоретаете велосипед
Обычное или управляемое прилажение?

Откройте типовую К и посм
Там настраивается - где хранить картинки - в базе или на диске

Ну типа того (велосипед)... Приложение управляемое!  К сожалению типовой нет.

ls600


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск