Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
07 Мар 2021, 04:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Получение цены для склада и номенклатуры на встроенном языке  (Прочитано 62 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн atom.e

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2021-02-21
  • Сайт: 
  • Профессия: Программист 1С
Добрый вечер помогите дописать логику получения цены для склада и номенклатуры


&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
ТекущаяСтрока
Идентификатор = Элементы.Товары.ТекущаяСтрока;
Если Идентификатор = Неопределено Тогда
Возврат; //исключаем ошибки в случае отсутствия данных
КонецЕсли;
СтрокаТоваров = Объект.Товары.НайтиПоИдентификатору(Идентификатор);
Если СтрокаТоваров = Неопределено Тогда
Возврат; //исключаем ошибки в случае отсутствия данных
КонецЕсли;
СтрокаТоваров.Сумма=Окр(СтрокаТоваров.Количество*СтрокаТоваров.Цена,2);
Если СкладРозничный() Тогда
СтрокаТоваров.ЦенаВРознице=Окр(СтрокаТоваров.Цена+СтрокаТоваров.Цена*НаценкаДляСклада(Идентификатор)/100);
КонецЕсли;
КонецПроцедуры

&НаСервере
Функция НаценкаДляСклада(Идентификатор)
Наценка = Константы.НаценкаПоУмолчанию.Получить();
СтрокаТоваров = Объект.Товары.НайтиПоИдентификатору(Идентификатор);
Если ЗначениеЗаполнено(СтрокаТоваров.Номенклатура) и ЗначениеЗаполнено(Объект.Склад) Тогда
Номенклатура = СтрокаТоваров.Номенклатура;
Склад = Объект.Склад;
//....
//Наценка = ...;

Конецесли;
Возврат Наценка;
КонецФункции


Теги:
 

"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 13211
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 4024
Последний ответ 29 Июн 2011, 21:11
от joyer
Как в реализации товаров и услуг во вкладке товары добавить столбец производитель (FA) в управление торговлей 11.1 1с предприятие? оно отсутствует в номенклатуре доступной при нажатии кнопки добавить как войти в настройки номенклатуры?

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 941
Последний ответ 25 Янв 2019, 10:07
от сергей123
Форма Номенклатуры + РегистрСведенийСписок (обычная форма)

Автор Алина ОсиповаРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 594
Последний ответ 21 Май 2020, 22:35
от Алина Осипова
Добавление колонки в "Установку цен номенклатуры"

Автор EtherialРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1251
Последний ответ 23 Окт 2018, 17:35
от Etherial

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
104 Сообщений
antoneus antoneus
30 Сообщений
Алексей_1985_06
29 Сообщений
LexaK
27 Сообщений
BuhRust
20 Сообщений
ls600 ls600
17 Сообщений
kah
13 Сообщений
DNN
11 Сообщений
DmitriyF DmitriyF
10 Сообщений
Ивашка
9 Сообщений

* Кто онлайн

  • Точка Гостей: 124
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal