Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 01:40

Получение цены для склада и номенклатуры на встроенном языке

Автор atom.e, 21 фев 2021, 19:07

0 Пользователей и 1 гость просматривают эту тему.

atom.e

Добрый вечер помогите дописать логику получения цены для склада и номенклатуры


&НаКлиенте
Процедура ТоварыЦенаПриИзменении(Элемент)
ТекущаяСтрока
Идентификатор = Элементы.Товары.ТекущаяСтрока;
Если Идентификатор = Неопределено Тогда
Возврат; //исключаем ошибки в случае отсутствия данных
КонецЕсли;
СтрокаТоваров = Объект.Товары.НайтиПоИдентификатору(Идентификатор);
Если СтрокаТоваров = Неопределено Тогда
Возврат; //исключаем ошибки в случае отсутствия данных
КонецЕсли;
СтрокаТоваров.Сумма=Окр(СтрокаТоваров.Количество*СтрокаТоваров.Цена,2);
Если СкладРозничный() Тогда
СтрокаТоваров.ЦенаВРознице=Окр(СтрокаТоваров.Цена+СтрокаТоваров.Цена*НаценкаДляСклада(Идентификатор)/100);
КонецЕсли;
КонецПроцедуры

&НаСервере
Функция НаценкаДляСклада(Идентификатор)
Наценка = Константы.НаценкаПоУмолчанию.Получить();
СтрокаТоваров = Объект.Товары.НайтиПоИдентификатору(Идентификатор);
Если ЗначениеЗаполнено(СтрокаТоваров.Номенклатура) и ЗначениеЗаполнено(Объект.Склад) Тогда
Номенклатура = СтрокаТоваров.Номенклатура;
Склад = Объект.Склад;
//....
//Наценка = ...;

Конецесли;
Возврат Наценка;
КонецФункции

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск