Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 дек 2021, 06:02

Посчитать значения в таблице

Автор Lazietow, 08 фев 2021, 22:49

0 Пользователей и 1 гость просматривают эту тему.

Lazietow

У  меня есть таблица с двумя колонками, в второй колонке написаны фамилии через запятую, как мне посчитать количество этих фамилий для каждой строки? Причем, это количество нужно присвоить первой колонке этой строки



Первый Лесников, Датов, Режкова...
ВторойМалых, Стопенко, Держанов...
ТретийЕще фамилии...

alexandr_ll

Цитата: Lazietow от 08 фев 2021, 22:49
У  меня есть таблица с двумя колонками, в второй колонке написаны фамилии через запятую, как мне посчитать количество этих фамилий для каждой строки? Причем, это количество нужно присвоить первой колонке этой строки



Первый Лесников, Датов, Режкова...
ВторойМалых, Стопенко, Держанов...
ТретийЕще фамилии...
Количество фамилий равно количеству запятых в строке плюс 1.
                Номер=0;
Пока Лев(СтрокаФамилий, 1)="," Цикл
                        Номер=Номер+1;
СтрокаФамилий=Сред(СтрокаФамилий, 2);
КонецЦикла;


antoneus

Цитата: alexandr_ll от 09 фев 2021, 07:23
Количество фамилий равно количеству запятых в строке плюс 1.
                Номер=0;
Пока Лев(СтрокаФамилий, 1)="," Цикл
                        Номер=Номер+1;
СтрокаФамилий=Сред(СтрокаФамилий, 2);
КонецЦикла;


СтрЧислоВхождений же есть)

alexandr_ll

Цитата: antoneus от 09 фев 2021, 09:56
Цитата: alexandr_ll от 09 фев 2021, 07:23
Количество фамилий равно количеству запятых в строке плюс 1.
                Номер=0;
Пока Лев(СтрокаФамилий, 1)="," Цикл
                        Номер=Номер+1;
СтрокаФамилий=Сред(СтрокаФамилий, 2);
КонецЦикла;


СтрЧислоВхождений же есть)
Да, первое, что пришло в голову. Конечно, число вхождений проще.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск