Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
06 дек 2021, 08:38

Объединение строк в таблице

Автор Lazietow, 08 фев 2021, 07:19

0 Пользователей и 1 гость просматривают эту тему.

Lazietow

Всем привет. У меня есть таблица с двумя колонками, строки в первой колонке часто повторяются. Как объединить эти повторения в одно, так чтобы значения из второй колонки писались через запятую? Помогите пожалуйста.



АбрамовМячи, шары
АбрамовИгрушки, ткани
Абрамовмячи, куклы



MuI_I_Ika

ТекущаяСтрока = Неопределено;
МассивДляУдаления = Новый Массив();

ТЗ.Сортировать("Контрагент");

Для каждого Элемент из ТЗ Цикл

    Если ТекущаяСтрока <> Неопределено и ТекущаяСтрока.Контрагент = Элемент.Контрагент Тогда

        ТекущаяСтрока.Номенклатура = ТекущаяСтрока.Номенклатура + Элемент.Номенклатура;
        МассивДляУдаления.Добавить(Элемент);

    Иначе

        ТекущаяСтрока = Элемент;

    КонецЕсли;

КонецЦикла;

Для каждого УдаляемыйЭлемент из МассивДляУдаления Цикл
    ТЗ.Удалить(УдаляемыйЭлемент);
КонецЦикла;

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск