Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
23 сен 2021, 14:31

Программное объединение ячеек в печатной форме 1с 8.3

Автор stydent117, 01 фев 2021, 09:37

0 Пользователей и 1 гость просматривают эту тему.

stydent117

Цитата: LexaK от 02 фев 2021, 16:23
так там же все по русски
Цитировать
Ожидается ключевое слово 'КонецФункции'
Обнаружено логическое завершение исходного текста модуля

честно говоря, я уже запутался.

но есть еще вариант!
называется: С Чистого листа!

все удаляете (и ни одной ошибки) и пишите заново

Функция ПечатьОтчетаКомитенту(МассивОбъектов, ОбъектыПечати)

ТабличныйДокумент = Новый ТабличныйДокумент;

Возврат ТабличныйДокумент;

КонецФункции




ЭЭЭэээ не,не, вот этого делать не нужно!!!Писака из меня такой себе
Функция ПечатьОтчетаКомитенту(МассивОбъектов, ОбъектыПечати)
   
    ТабличныйДокумент = Новый ТабличныйДокумент;

    Возврат ТабличныйДокумент;

КонецФункции

-создаем макет,я правильно думаю?
Я готов,что далее?

LexaK

ЦитироватьЯ готов,что далее?
э-э-э-э, а я откуда знаю? у вас же задача!

что-то там напечатать да еще с хитро объединенными областями!
это как говорится: ваши пирожные - вам и трескать
ответ Понравился? (в смысле пригодился?)

stydent117

Цитата: LexaK от 02 фев 2021, 17:20
ЦитироватьЯ готов,что далее?
э-э-э-э, а я откуда знаю? у вас же задача!

что-то там напечатать да еще с хитро объединенными областями!
это как говорится: ваши пирожные - вам и трескать

Если НужноОбъединение Тогда
    ОбластьМакета = Макет.ПолучитьОбласть("СтрокаОбъединенная");
Иначе   
    ОбластьМакета = Макет.ПолучитьОбласть("СтрокаОбычная");
КонецЕсли;

Ошибка вылезла :Переменная НужноОбъединение  не определена...

Я понял почему код не вставал,я полностью копировал  макет и получение области
Отец вернись,я все прощу...
Добавлено: 03 фев 2021, 10:16


В какую сторону дальше двигаться? Help me :dfbsdfbsdf:

LexaK

1.восстановите из бакапа все как было
2.измените Макет, на нужный, с нужными объединениями,

постарайтесь не изменять параметры, тогда в коде вообще ни чего менять не надо будет.

в итоге получится старая программа, которая выводит новый/измененный макет.
Макеты менять/дорабатывать умеете?
ответ Понравился? (в смысле пригодился?)

stydent117

Цитата: LexaK от 03 фев 2021, 10:44
1.восстановите из бакапа все как было
2.измените Макет, на нужный, с нужными объединениями,

постарайтесь не изменять параметры, тогда в коде вообще ни чего менять не надо будет.

в итоге получится старая программа, которая выводит новый/измененный макет.
Макеты менять/дорабатывать умеете?
это я запомнил- Макет, это как бы набор заготовок, где вы, по определенному условию берете нужную область, заполняете ее и выводите в печатную форму (в табличный документ

Макеты менять/дорабатывать умеете? Добавить ячейку/написать формулу /а вот объединение у меня первый раз



LexaK

Цитироватьа вот объединение у меня первый раз
дааа,
там-же в конструкторе/ редакторе макета, выделяете мышкой несколько ячеек,
нажать ПКМ (правая кнопка мышки) из контекстного меню выбрать: Объединить (Ctrl+M)
ответ Понравился? (в смысле пригодился?)

stydent117

Цитата: LexaK от 03 фев 2021, 11:07
Цитироватьа вот объединение у меня первый раз
дааа,
там-же в конструкторе/ редакторе макета, выделяете мышкой несколько ячеек,
нажать ПКМ (правая кнопка мышки) из контекстного меню выбрать: Объединить (Ctrl+M)
Я не через скд делаю,без конструктора

LexaK

ответ Понравился? (в смысле пригодился?)

stydent117

Цитата: LexaK от 03 фев 2021, 11:20
при чем здесь СКД?
это не СКД, а конфигуратор
конструкторе/ редакторе макета-а где этот раздел находится?
Добавлено: 03 фев 2021, 11:40


Цитата: LexaK от 03 фев 2021, 11:20
при чем здесь СКД?
это не СКД, а конфигуратор
Конструктор недоступен так как данный документ является расширением для конфигурации
Добавлено: 03 фев 2021, 11:53


Цитата: LexaK от 03 фев 2021, 11:20
при чем здесь СКД?
это не СКД, а конфигуратор
нажать ПКМ (правая кнопка мышки) из контекстного меню выбрать: Объединить (Ctrl+M)---Это горизонтальное объединение,а нужно вертикально часть строки при выводе в печатную форму

ls600

что мешает объединить вертикальные ячейки

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск