Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2021, 20:09

Открытие формы выбора

Автор Алексей_1985_06, 27 янв 2021, 19:56

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Ребята все привет! Подскажите, создана обработка всего с 2-мя реквизитами: СемейноеПоложение (тип: ПеречислениеСсылка) и Сотрудник (тип: СправочникСсылка), необходимо при выборе семейного положения, если значение: Холост, автоматически открывать форму списка сотрудников у которых реквизит "Семейное положение" = холостой. Сейчас форма выбора открывается без такого отбора и почему-то элемент не выбирается (при двойном щелчке). Подскажите пжл как исправить?
&НаКлиенте
Процедура СемейноеПоложениеПриИзменении(Элемент)

Холостой = ПредопределенноеЗначение("Перечисление.СемейноеПоложение.Холост");
Если СемейноеПоложение = Холостой И Сотрудник.Пустая() 
Тогда
ПараметрыФормы = Новый Структура("Ключ", Холостой);
ОткрытьФорму("Справочник.Сотрудники.ФормаВыбора", ПараметрыФормы);
КонецЕсли;
КонецПроцедуры


LexaK


&НаКлиенте
Процедура СемейноеПоложениеПриИзменении(Элемент)
   
     Холостой = ПредопределенноеЗначение("Перечисление.СемейноеПоложение.Холост");
     Если СемейноеПоложение = Холостой И Сотрудник.Пустая() 
        Тогда
ПараметрыФормы = Новый Структура("Ключ", Холостой);
ОткрытьФорму("Справочник.Сотрудники.ФормаВыбора", ПараметрыФормы);
        КонецЕсли;
КонецПроцедуры


не надо ничего этого, в конструкторе формы обработки, для поля элемента Сотрудник укажите связь между параметрами выбора
и все будет работать автоматом, без кода.
ответ Понравился? (в смысле пригодился?)

Алексей_1985_06

Цитата: LexaK от 28 янв 2021, 10:30

&НаКлиенте
Процедура СемейноеПоложениеПриИзменении(Элемент)
   
     Холостой = ПредопределенноеЗначение("Перечисление.СемейноеПоложение.Холост");
     Если СемейноеПоложение = Холостой И Сотрудник.Пустая() 
        Тогда
ПараметрыФормы = Новый Структура("Ключ", Холостой);
ОткрытьФорму("Справочник.Сотрудники.ФормаВыбора", ПараметрыФормы);
        КонецЕсли;
КонецПроцедуры


не надо ничего этого, в конструкторе формы обработки, для поля элемента Сотрудник укажите связь между параметрами выбора
и все будет работать автоматом, без кода.

LexaK Ё-моё точно... :zebzdr: а я мучаюсь....:dfbbdrfb: Большое спасибо!!!! Теперь все как надо отрабатывает.....

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск