Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
19 сен 2021, 20:20

Подведение итогов

Автор Максим Березовский, 24 янв 2021, 12:30

0 Пользователей и 1 гость просматривают эту тему.

Максим Березовский

Почему выдает ошибку

Процедура Печать_()
Спр = СоздатьОбъект ("Справочник. Абитуриенты");
Спр. ИспользоватьДату (ИспользоватьДату ());
Если ИспользоватьВладельца ().Выбран () = 1 Тогда
Спр. ИспользоватьВладельца (ИспользоватьВладельца ());
Иначе
Возврат;
КонецЕсли;
Таб = СоздатьОбъект ("Таблица");
Таб. ИсходнаяТаблица ("Печать_");
Таб. ВывестиСекцию ("Шапка");
Таб. Опции (0,0,Таб. ВысотаТаблицы (),0);
Спр. ВыбратьЭлементы ();
Пока Спр. ПолучитьЭлемент () = 1 Цикл
Если Спр. ЭтоГруппа () = 1 Тогда
Таб. ВывестиСекцию ("Группа");
Иначе
Таб. ВывестиСекцию ("Строка");
КонецЕсли;
КонецЦикла;
Итого = Итог ("Средний_Бал");
Таб. ВывестиСекцию ("Подвал");
Таб. ТолькоПросмотр (1);
Таб. Показать ("Печать Абитуриенты","");
КонецПроцедуры

Меня интересует эта строка кода Итого = Итог ("Средний_Бал");
Буду благодарен если поможете вывести Итог по столбцу средний_бал в таблицу при печати

Ошибка
Таблица

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск