Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 авг 2021, 13:55

постоянное соединение на &сервере

Автор Tlrd2, 22 янв 2021, 20:05

0 Пользователей и 1 гость просматривают эту тему.

Tlrd2

Добрый день!
  Нужно раз в 2 секунды через web-сервисы,необходимо делать запросы к другому ПО из сеанса пользователя.
   
Подскажите как при запуске системы/обработки создать 1 сессию соединения по HTTP к интеграционному сервису другой системы и пока пользователь работает ,каждые несколько секунд отправлять запросы ?
Цель - сократить время обработки за счёт создания нового соединения

Как я понимаю , подобная конструкция может быть только на сервере :
    Определения           =  Новый WSОпределения("http://192.168.1.2:10101/.....");   
    Прокси                =  Новый WSПрокси(Определения, "http://parsec.ru/Parsec3IntergationService","IntegrationService","IntegrationServiceSoap12";);
А  обработчик  Обработчики ожидания (ПодключитьОбработчикОжидания) работает только на клиенте.

LexaK

вроде работает такой вариант
объявляете переменную на сервере
&НаСервере
ВебСоединение;

в серверной процедуре проверяете и используете, примерно так
&НаСервере
Процедура ВебОбменНаСервере()
    Если ВебСоединение = Неопределено Тогда
        ВебСоединение = УстановистьСоединение(...);
    КонецЕсли
    //ваш код с ВебСоединение - ем
    ...
КонецПроцедуры;

клиентская процедура для помещаете в обработчик ожидания
&НаКлиенте
Процедура ВебОбменНаКлиенте()
    ВебОбменНаСервере();
КонецПроцедуры;

на форме
&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПодключитьОбработчикОжидания("ВебОбменНаКлиенте",5);
КонецПроцедуры
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск