Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 00:29

Не могу программно изменить реализации

Автор grigorov1976, 22 янв 2021, 15:40

0 Пользователей и 1 гость просматривают эту тему.

grigorov1976

Добрый день, форумчане!
Проблема: Пытаюсь программно изменить реализацию товаров и услуг из обработки. Отладчик показывет, что все выполняется без ошибок. Но реализации почему-то не изменяются. 1С:Предприятие 8.3 (8.3.17.1851), Бухгалтерия предприятия, редакция 3.0 (3.0.87.28). Код ниже.

&НаСервере
Процедура ОбработатьНаСервере(ДанныеДляЗаполнения)
   НомеклатураДляЗаполнения = Справочники.Номенклатура.НайтиПоКоду("БП-00001443");
   Для Каждого СтрокаРеализации Из ДанныеДляЗаполнения Цикл
      РеализацияСсылка = Документы.РеализацияТоваровУслуг.НайтиПоНомеру(СтрокаРеализации.НомерРеализации, Дата(2020,01,01));
      Реализация = РеализацияСсылка.ПолучитьОбъект();
      Счет = Реализация.СчетНаОплатуПокупателю.ПолучитьОбъект();
      Если СтрокаРеализации.НужнаяСумма = 0 Тогда
         Реализация.УстановитьПометкуУдаления(Истина);
         Реализация.Записать(РежимЗаписиДокумента.ОтменаПроведения);
         Счет.УстановитьПометкуУдаления(Истина);
         Счет.Записать(РежимЗаписиДокумента.ОтменаПроведения);
         Сообщить("Удалена " + Реализация.Ссылка);
         Сообщить("Удален " + Счет.Ссылка);
      Иначе
         Реализация.Записать(РежимЗаписиДокумента.ОтменаПроведения);
         Товары = Реализация.Товары;
         Товары.Очистить();
         Товар = Товары.Добавить();
         
         //Пока Товары.Количество() > 1 Цикл
         //   Товары.Удалить(0);
         //КонецЦикла;
         //Товар = Товары[0];
         
         Товар.Номенклатура = НомеклатураДляЗаполнения;
         Товар.Цена = СтрокаРеализации.НужнаяСумма;
         Товар.Количество = 1;
         Товар.Сумма = СтрокаРеализации.НужнаяСумма;
         Товар.СуммаНДС = Окр(СтрокаРеализации.НужнаяСумма/6, 2);
         Товар.Субконто =
         Реализация.СуммаДокумента = СтрокаРеализации.НужнаяСумма;
         Реализация.Записать(РежимЗаписиДокумента.Проведение);
         
         Товары = Счет.Товары;
         Пока Товары.Количество() > 1 Цикл
            Товары.Удалить(0);
         КонецЦикла;
         Товар = Товары[0];
         Товар.Номенклатура = НомеклатураДляЗаполнения;
         Товар.Цена = СтрокаРеализации.НужнаяСумма;
         Товар.Количество = 1;
         Товар.Сумма = СтрокаРеализации.НужнаяСумма;
         Товар.СуммаНДС = Окр(СтрокаРеализации.НужнаяСумма/6, 2);
         Счет.СуммаДокумента = СтрокаРеализации.НужнаяСумма;
         Счет.Записать(РежимЗаписиДокумента.Проведение);

         Сообщить("Изменена сумма для " + Реализация.Ссылка + " с " + СтрокаРеализации.БывшаяСумма + " на " + СтрокаРеализации.НужнаяСумма);
         Сообщить("Изменена сумма для " + Счет.Ссылка + " с " + СтрокаРеализации.БывшаяСумма  + " на " + СтрокаРеализации.НужнаяСумма);
      КонецЕсли;
   КонецЦикла;
КонецПроцедуры


Что я делаю не так?

LexaK

ну-ну, БП 3.0, прошлый год, период наверняка ЗАКРЫТ!!! и чего вы там хотите изменить?
правда должна ругаться на период или еще на что-то, но мы же не видим всей картины!
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск