Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 дек 2021, 00:20

Исправление ошибок

Автор GBV, 22 янв 2021, 04:03

0 Пользователей и 1 гость просматривают эту тему.

GBV

Здравствуйте, в программировании недавно начал разбираться, еще ничего не знаю
надо переписать код. Помогите пожалуйста
Запрос = Параметры.ЗапросСКэшемПартнеров;
      Если ТекУзел = Перечисления.СписокУзловОбмена.СкладРосич Тогда
         Массив = Новый Массив;
         Массив.Добавить(Справочники.Контрагенты.НайтиПоКоду("Ц00004929"));
      Запрос.Текст = Запрос.Текст+"   
      |  И ВЫБОР КОГДА ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_MOV""
      |  И ТИПЗНАЧЕНИЯ(ВТ_ТабСообщений_Внешняя.Документ) = ТИП(Документ.РеализацияТоваровУслуг)
      |  И СпрКонтрагенты.Ссылка В ИЕРАРХИИ(&Подразделения)"
      |                                                ТОГДА ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_MOV"" ЛОЖЬ
      |                                ИНАЧЕ ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_DES"" ИСТИНА
      |                КОНЕЦ";
      ЗапросСКэшемПартнеров.Текст=СтрЗаменить(ЗапросСКэшемПартнеров.Текст, ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_MOV"",ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_DES"");
      Запрос.УстановитьПараметр("СписокГруппСклада",Массив);
      Параметры.Вставить("ЗапросСКэшемПартнеров",Запрос);
        КонецЕсли;


{ВнешняяОбработка.КонтурEDI_ПодключаемыйМодуль.МодульОбъекта(833,3)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
      <<?>>|                                                ТОГДА ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_MOV"" ЛОЖЬ (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.КонтурEDI_ПодключаемыйМодуль.МодульОбъекта(834,83)}: Ожидается ключевое слово 'КонецЕсли' ('EndIf')
      |                                ИНАЧЕ ВТ_ТабСообщений_Внешняя.ТипСообщения = ""<<?>>M_DES"" ИСТИНА (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.КонтурEDI_ПодключаемыйМодуль.МодульОбъекта(836,113)}: Ожидается символ ','
      ЗапросСКэшемПартнеров.Текст=СтрЗаменить(ЗапросСКэшемПартнеров.Текст, ВТ_ТабСообщений_Внешняя.ТипСообщения = ""<<?>>M_MOV"",ВТ_ТабСообщений_Внешняя.ТипСообщения = ""M_DES""); (Проверка: Толстый клиент (обычное приложение))
{ВнешняяОбработка.КонтурEDI_ПодключаемыйМодуль.МодульОбъекта(838,54)}: Обнаружено логическое завершение исходного текста модуля
      Параметры.Вставить("ЗапросСКэшемПартнеров",Запрос);<<?>> (Проверка: Толстый клиент (обычное приложение))


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск