Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
02 дек 2021, 06:59

Доработка формы списка документов, добавление колонки

Автор Сергей Поляков, 13 янв 2021, 17:44

0 Пользователей и 1 гость просматривают эту тему.

Сергей Поляков

Всем здравствуйте.
Подскажите пожалуйста как можно реализовать такой функционал:

Имеется база данных Далион, обычные формы.
нужно в форме списка приходных накладных по каждой строке выводить информацию оплачена она или нет.

Я добавил реквизит "оплата", разместил его на форме списка.

дальше не могу понять как в этой колонке для каждой строки заполнить сумму оплаты.
запросом я данные получил нужные, а вот в каком обработчике и как записать, не разобрался.

пробовал "при активации строки". сообщение() - срабатывает.
а если так: ЭлементыФормы.ДокументСписок.ТекущаяСтрока = Выборка.Значения;
так не срабатывает - пишет что это только для чтения, записать нельзя.
а хотелось бы не при активации каждой строки, а просто при открытии формы списка чтобы для каждой строки заполниилсь суммы долга.
событие "ПриОткрытии"
Но как записать значение в стоки для колонки, подскажите пожалуйста?

LexaK

в форме с таблицей документов есть событие ПриВыводеСтроки

Процедура ТаблицаРезультатаПриВыводеСтроки(Элемент, ОформлениеСтроки, ДанныеСтроки)

лкТекст = "";
Если ПолучитьТекстОплаты(ДанныеСтроки[лкКол.Имя], лкТекст) Тогда
лкЯчейка = ОформлениеСтроки.Ячейки["Оплата"];
Если лкЯчейка.Текст <> лкТекст Тогда
лкЯчейка.УстановитьТекст(лкТекст);
//лкЯчейка.ЦветТекста = WebЦвета.Синий;
КонецЕсли;
КонецЕсли;

КонецПроцедуры

примерно так,

или по другому при обработке события ПриПолученииДанных
ответ Понравился? (в смысле пригодился?)

Сергей Поляков

спасибо за ответ. завтра проверю.
скажите а событие событие приВыводеСтроки в какой момент срабатывает?

LexaK

ну мистер Очевидность, наверно тогда когда она выводится в видимую часть формы, список документов может быть очень большим и не все строчки списка попадают в страницы отображения
ответ Понравился? (в смысле пригодился?)

Сергей Поляков

Спасибо все получилось. добавил колонку не связанную с данными

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск