Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
21 Янв 2021, 21:19
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Неправильно считает возраст в СКД  (Прочитано 149 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Алексей_1985_06

  • ***
  • Сообщений: 148
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-09-01
  • Сайт: 
  • Профессия: Ученик 1С
Всем привет! Подскажите в чем может быть ошибка:
1. Есть процедура в общем модуле (расчет возраста сотрудника)
Функция ВозрастСотрудника(ДатаРождения) Экспорт 
Если ДатаРождения <> '00010101000000' Тогда // Проверка на пустую дату
ДатаТекущая = Год(ТекущаяДата())*10000 + Месяц(ТекущаяДата())*100 + День(ТекущаяДата());
ДатаИскомая = Год(ДатаРождения)*10000 + Месяц(ДатаРождения)*100 + День(ДатаРождения);   
КоличествоЛет = Цел((ДатаТекущая-ДатаИскомая)/10000); 
Возраст = СтрокаСЧислом("; %1 год;; %1 года; %1 лет;", КоличествоЛет, ВидЧисловогоЗначения.Количественное, "L=ru");
Возврат (Возраст)
КонецЕсли;
КонецФункции
2. В СКД создал вычисляемое поле "Возраст" Выражение: ВызовСервера.ВозрастСотрудника (Сотрудник.ДатаРождения)
Но почему-то расчет возраста сотрудника (у которого дата рождения отсутствует) все равно происходит...неправильно (скрин во вложении)
Подскажите в чем "затыка" ?


Оффлайн LexaK

  • *****
  • Сообщений: 2369
  • РЕПУТАЦИЯ: 706
  • КПД: 30%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
попробуйте так
Функция ВозрастСотрудника(ДатаРождения) Экспорт 

Если ЗначениеЗаполнено(ДатаРождения) Тогда // Проверка на пустую дату
    ДатаТекущая = Год(ТекущаяДата())*10000 + Месяц(ТекущаяДата())*100 + День(ТекущаяДата());
    ДатаИскомая = Год(ДатаРождения)*10000 + Месяц(ДатаРождения)*100 + День(ДатаРождения);   
    КоличествоЛет = Цел((ДатаТекущая-ДатаИскомая)/10000); 
    Возраст = СтрокаСЧислом("; %1 год;; %1 года; %1 лет;", КоличествоЛет, ВидЧисловогоЗначения.Количественное, "L=ru");   
Иначе
Возраст = "<Нет даты рождения>";
КонецЕсли;

    Возврат Возраст;

КонецФункции
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн Алексей_1985_06

  • ***
  • Сообщений: 148
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-09-01
  • Сайт: 
  • Профессия: Ученик 1С
попробуйте так
Функция ВозрастСотрудника(ДатаРождения) Экспорт 

Если ЗначениеЗаполнено(ДатаРождения) Тогда // Проверка на пустую дату
    ДатаТекущая = Год(ТекущаяДата())*10000 + Месяц(ТекущаяДата())*100 + День(ТекущаяДата());
    ДатаИскомая = Год(ДатаРождения)*10000 + Месяц(ДатаРождения)*100 + День(ДатаРождения);   
    КоличествоЛет = Цел((ДатаТекущая-ДатаИскомая)/10000); 
    Возраст = СтрокаСЧислом("; %1 год;; %1 года; %1 лет;", КоличествоЛет, ВидЧисловогоЗначения.Количественное, "L=ru");   
Иначе
Возраст = "<Нет даты рождения>";
КонецЕсли;

    Возврат Возраст;

КонецФункции

LexaK что бы я без Вас делал..... Очередной раз ОГРОМНОЕ ВАМ СПАСИБО ЗА ПОМОЩЬ !!!  :ooifh::ooifh::ooifh:


Теги:
 

В док. Отпуск сотрудников считает рабочие и не рабочие дни.

Автор Stanislav GareevРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 373
Последний ответ 02 Окт 2019, 05:58
от alexandr_ll
Вычет по НДС не будет предоставлен, если в счет-фактуре неправильно указаны стоимость товара или сумма НДС

Автор newsРаздел Новости

Ответов: 0
Просмотров: 1271
Последний ответ 16 Окт 2014, 12:04
от news
Неправильно работает отбор по дате в методе ПолучитьЗаголовки интеренет почты (MS Exchange)

Автор MaximBРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 1237
Последний ответ 20 Фев 2017, 09:45
от MaximB
Таблица значений на форме неправильно возвращает номер текущей строки

Автор IgorJРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 9
Просмотров: 16415
Последний ответ 25 Июн 2013, 22:12
от Dethmontt
Неправильно работает отчет Валовая прибыль в КА/УПП 8.2 со свойствами объектов

Автор RuschelРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 3141
Последний ответ 15 Фев 2012, 18:30
от Ruschel

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

LexaK
49 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
28 Сообщений
prolog
25 Сообщений
antoneus antoneus
25 Сообщений
Алексей_1985_06
25 Сообщений
vadim10121995
24 Сообщений
DmitriyF DmitriyF
16 Сообщений
alexandr_ll
16 Сообщений
Сергей Поляков Сергей Поляков
6 Сообщений
altair2019
6 Сообщений

* Кто онлайн

  • Точка Гостей: 281
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal