Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
28 ноя 2021, 19:55

Помогите с кодом (проверка при записи)

Автор Алексей_1985_06, 09 янв 2021, 11:47

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем привет! Подскажите пжл, при записи элемента справочника, происходит проверка чтоб нельзя было записать две должности с соответствующей отметкой командира одного подразделения, и все вроде бы работает.... Но только в данном случае, при изменении любого реквизита, например "Классификации должности" и последующий записи элемента - инициируется эта самая проверка и соответственно записать элемент нельзя, что крайне не удобно.... Подскажите как можно оптимизировать это? :dfbsdfbsdf::dfbsdfbsdf::dfbsdfbsdf:


Процедура ПередЗаписью(Отказ)

Если КомандирСтруктурногоПодразделения  Тогда
Запрос = Новый Запрос;
Запрос.Текст = "ВЫБРАТЬ
| ШтатныеДолжности.Владелец КАК Подразделение,
| ШтатныеДолжности.Ссылка КАК Должность,
| ШтатныеДолжности.КомандирСтруктурногоПодразделения КАК Командир
|ИЗ
| Справочник.ШтатныеДолжности КАК ШтатныеДолжности
|ГДЕ
| ШтатныеДолжности.КомандирСтруктурногоПодразделения = ИСТИНА
| И ШтатныеДолжности.Владелец = &Подразделение";
Запрос.УстановитьПараметр("Подразделение",Владелец);
Результат = Запрос.Выполнить();
Выборка = Результат.Выбрать();
Если НЕ Результат.Пустой() Тогда
Выборка.Следующий();

Сообщение = Новый СообщениеПользователю;
Сообщение.Поле = "КомандирСтруктурногоПодразделения";
Сообщение.УстановитьДанные(ЭтотОбъект); 
Сообщение.Текст = "Руководитель уже определен...";
Сообщение.Сообщить();
Отказ = Истина; // отказ от записи
    КонецЕсли;
КонецЕсли;
КонецПроцедуры




Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск