Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
27 Май 2018, 16:57
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Проблема при изучении программы по самоучителю  (Прочитано 2227 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Dobriymart

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Судите меня строго - учусь я прилежно
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Ученик 1С
Добрый день! Подскажите пожалуйста! Изучаю по программе 1С работу с "Полем списка". Задание урока - создать сомозопалняющееся поле спика, а потом при наведении на одно из значений в Элементе надпись отображаеться значени с поля списка. Всё сделал по самоучителю, уже 5 раз перепроверил и нескольок раз перенобрал, но программа не работатет. Точенее не воодит Данные в ПолеСписка1. Укажите в чём моя ошибка, пожалуйста! Код и Скрины прилагаються :

Процедура ПриОткрытии()
   // Вставить содержимое обработчика.
   Для л = 1 по 10 Цикл
      ПолеСписка1.Добавить("строка"+л,,,);
   КонецЦикла;
КонецПроцедуры

Процедура ПолеСписка1Выбор(Элемент, ЭлементСписка)
   // Вставить содержимое обработчика.
   ЭлементыФормы.Надпись1.Заголовок = ЭлементСписка;
КонецПроцедуры


Оффлайн Dobriymart

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Судите меня строго - учусь я прилежно
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Ученик 1С
Сразу доп вопрос =) Зачем в строке

"ПолеСписка1.Добавить("строка"+л,,,);"

после "л" ставить ",,," - ???

Оффлайн cska-fanat-kz

  • 1С:Специалист
  • Глобальный модератор
  • *****
  • Сообщений: 5745
  • РЕПУТАЦИЯ: 1099
  • КПД: 19%
  • Красная армия всех сильней!
  • Регистрация: 2010-11-06
    • Skype: cska-fanat-kz81
  • Сайт: cska-fanat-kz.ucoz.kz
  • Профессия: Разработчик 1С
Код процедуры ПриОткрытии() - правильный.
Сама процедура привязана к событию "ПриОткрытии"?
Получил помощь - скажи СПАСИБО.
Разобрался сам - расскажи другим.

Оффлайн Dobriymart

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Судите меня строго - учусь я прилежно
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Ученик 1С
Код процедуры ПриОткрытии() - правильный.
Сама процедура привязана к событию "ПриОткрытии"?
Вы не поверите - "Нет"!  :xfbnsdfb: Спасибо! В настройках формы - События - Поставил "При открытии" - Заработало. :zebzdr:

Но теперь то у меня не показывает в элементе НАДПИСЬ  <_< - выбранное значение с ПоляСписка1, хотя в настройках формы - События - я тоже поставил на Обрабоку выбора : "ПолеСписка1Выбор" Скрин прикрепляю!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Попробуйте в заголовок надписи присваивать не ЭлементСписка, а ЭлементСписка.Значение.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать

Оффлайн Dobriymart

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Судите меня строго - учусь я прилежно
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте в заголовок надписи присваивать не ЭлементСписка, а ЭлементСписка.Значение.

Не помогло =(

Оффлайн Dobriymart

  • *
  • Сообщений: 17
  • РЕПУТАЦИЯ: 0
  • Судите меня строго - учусь я прилежно
  • Регистрация: 2011-04-11
  • Сайт: 
  • Профессия: Ученик 1С
Попробуйте в заголовок надписи присваивать не ЭлементСписка, а ЭлементСписка.Значение.

А Оказіваеться, нужно біло в Свойствах Поле списка - поставить в собітии Выбор - ПолеСписка1! О Господи! я свихнусь с этйо программой и самоучителем - мучителем!

Оффлайн Klyacksa

  • Фрилансер. Милости прошу с задачами в личку.
  • Глобальный модератор
  • *****
  • Сообщений: 1325
  • РЕПУТАЦИЯ: 430
  • КПД: 32%
  • Регистрация: 2010-08-20
  • Сайт: 
  • Профессия: Программист 1С
Да, проблема некоторых самоучителей и методичек в том, что разные разделы пишут разные люди, и не очень-то внимательно читают то, что написали до них. Часто встречаются несостыковки в мелочах, которые привносят нерабочие моменты в программу... Ну зато читателю придется думать, что он делает, а не бездумно переписывать.
xxx: Спасибо! Я бы загуглил, но ты интересней. Материшься. Злишься. Послать можешь...

Мысль - это оргазм мозга. Кто способен его испытать - получают истинное наслаждение, остальным приходится имитировать


Теги:
 

Проблема с выгрузкой НН в "Звит" Не найдено соответствие для схемы "J1201008"

Автор AldemaHРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 1387
Последний ответ 06 Июл 2016, 09:19
от AldemaH
проблема с "ЗагрузкаДанныхИзТабличногоДокумента"

Автор bratmaratРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 5305
Последний ответ 08 Янв 2014, 14:30
от LordWizard
Проблема с развертыванием окон и сохранением окон

Автор SokresРаздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 3140
Последний ответ 09 Дек 2015, 14:09
от pavl_vs
Проблема с отчетом "Перемещение товаров"

Автор sailРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 3688
Последний ответ 14 Дек 2010, 20:27
от progmikon
1C 8.2 УПП проблема с отчетом "Задолженость по контрагентам"

Автор LeonidLeonidРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 3999
Последний ответ 26 Сен 2011, 20:42
от Dethmontt

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

Смотрите бесплатно более 300 видеоуроков по работе в 1С:Бухгалтерия 8 и 1C:ЗУП 8 ред. 3.0

СМОТРЕТЬ >>

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
alex0402
67 Сообщений
AIFrame AIFrame
56 Сообщений
oleg-x
56 Сообщений
buketov.av buketov.av
47 Сообщений
wise wise
41 Сообщений
ilyay ilyay
39 Сообщений
Анюта17
33 Сообщений
Alter
32 Сообщений
trialex3
30 Сообщений

* Кто онлайн

  • Точка Гостей: 235
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal