Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Дек 2020, 08:14
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Расшифровка  (Прочитано 147 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Ивашка

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-08-27
  • Сайт: 
  • Профессия: Ученик 1С
Приветствую, создал внешний отчет "Незаполненные сотрудники", в отчете есть колонки Вход и Выход и по нажатию на ячейку колонок вход или выход, открывать форму регистра Данные КПП с текущей записью, для возможности ее заполнить в ручную.
Создал форму отчета и написал обработку расшифровки, но что то выводит пустую форму записи, в чём ошибка?
&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)

СтандартнаяОбработка = Ложь;     
    ЗначениеВЯчейке = ПолучитьЗначениеВЯчейке(Расшифровка,"ПериодВхода");
ОткрытьФорму("РегистрСведений.ДанныеКПП.ФормаЗаписи", Новый Структура("Ключ",ЗначениеВЯчейке));

КонецПроцедуры

&НаСервере
Функция ПолучитьЗначениеВЯчейке(Расшифровка,ИмяПоля)
   
    РасшифровкаДанные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);
  ПоляРасшифроки = РасшифровкаДанные.Элементы.Получить(Расшифровка).ПолучитьПоля();

НайденноеПоле = ПоляРасшифроки.Найти(ИмяПоля);
Если НайденноеПоле = Неопределено Тогда
Возврат Неопределено;
Иначе
Возврат НайденноеПоле.Значение;
КонецЕсли;

КонецФункции

Последний раз редактировалось: Ивашка; 15 Ноя 2020, 20:57


Оффлайн LexaK

  • *****
  • Сообщений: 2299
  • РЕПУТАЦИЯ: 682
  • КПД: 30%
  • Регистрация: 2012-05-16
  • Сайт: 
  • Профессия: Программист 1С
Re: Расшифровка
« Ответ #1: 16 Ноя 2020, 10:23 »
ключ записи, это более сложная конструкция, чем просто какое-то значение, как правила структура с кучей полей
вот какой-то пример как это вызывается
    ...	
ЗначениеКлюча = Новый Массив;
ЗначениеКлюча.Добавить(ПараметрыЗаписи);
КлючЗаписи = Новый("РегистрСведенийКлючЗаписи.ФискальныеОперации", ЗначениеКлюча);
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("Ключ", КлючЗаписи);
ОткрытьФорму("РегистрСведений.ФискальныеОперации.Форма.ФормаЗаписи", ПараметрыФормы, Форма);
    ...
Помогло? - Нажми СПАСИБО (под аватаром) !!!
                       :)

Оффлайн Ивашка

  • *
  • Сообщений: 31
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2019-08-27
  • Сайт: 
  • Профессия: Ученик 1С
Re: Расшифровка
« Ответ #2: 16 Ноя 2020, 11:16 »
А параметр записи что это?
у Меня не работает позиционирование. И не пойму почему в ключе записи появляется период как пустая дата и регистратор как неопределено. в чем ошибка?
Добавлено: 16 Ноя 2020, 11:42

&НаКлиенте
Процедура РезультатОбработкаРасшифровки(Элемент, Расшифровка, СтандартнаяОбработка, ДополнительныеПараметры)

СтандартнаяОбработка = Ложь; 
КлючЗаписиРегистра = ПолучитьЗначениеВЯчейке(Расшифровка);

ЗначениеКлюча = Новый Массив;
ЗначениеКлюча.Добавить(КлючЗаписиРегистра);
КлючЗаписи = Новый("РегистрСведенийКлючЗаписи.ДанныеКПП", ЗначениеКлюча);
ПараметрыФормы = Новый Структура;
ПараметрыФормы.Вставить("Ключ", КлючЗаписи);
ОткрытьФорму("РегистрСведений.ДанныеКПП.ФормаЗаписи", ПараметрыФормы, ЭтаФорма);

КонецПроцедуры

&НаСервере
Функция ПолучитьЗначениеВЯчейке(знач Расшифровка)
   
РасшифровкаДанные = ПолучитьИзВременногоХранилища(ДанныеРасшифровки);

Если РасшифровкаДанные.Элементы[Расшифровка].ПолучитьПоля()[0].Поле = "ФизическоеЛицо" Тогда
Возврат Неопределено;
КонецЕсли;

//найдём первое значение в строке
Пока РасшифровкаДанные.Элементы[Расшифровка].ПолучитьПоля()[0].Поле <> "ПериодВхода" Цикл
    Расшифровка = Расшифровка - 1;
КонецЦикла;

Значение = Новый Структура("ПериодВхода,ПериодВыхода,ФизическоеЛицо",
РасшифровкаДанные.Элементы[Расшифровка].ПолучитьПоля()[0].Значение,
РасшифровкаДанные.Элементы[Расшифровка+1].ПолучитьПоля()[0].Значение);
       
//найдём физлицо 
Пока Число(Расшифровка) > 0 Цикл
    Расшифровка = Расшифровка - 1;
Попытка
ПараметрыПоля = РасшифровкаДанные.Элементы[Расшифровка].ПолучитьПоля()[0];
Исключение
Продолжить;
КонецПопытки;
   
    Если ПараметрыПоля.Поле = "ФизическоеЛицо" Тогда
        Значение.ФизическоеЛицо = ПараметрыПоля.Значение;
        Прервать;
    КонецЕсли;
КонецЦикла;

Возврат РегистрыСведений.ДанныеКПП.СоздатьКлючЗаписи(Значение);
     
   
КонецФункции

записал так, но ничего не меняется(((

Последний раз редактировалось: Ивашка; 16 Ноя 2020, 11:42. Причина: Объединение сообщений


Теги:
 

выгрузка в УПП через Конвертацию "Проведение документа: Платежное поручение исходящее Не совпадают сумма документа и ее расшифровка"

Автор Св ЧРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 6
Просмотров: 1321
Последний ответ 03 Янв 2019, 00:00
от Св Ч
Отчет - расшифровка по статье затрат "услуги автотранспорта"

Автор marismurРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 2
Просмотров: 4399
Последний ответ 22 Авг 2014, 14:36
от morph1991
Расшифровка в отчете на СКД, который вызывается из формы справочника(управляемые формы)

Автор anna_vsРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 19
Просмотров: 12327
Последний ответ 09 Дек 2015, 14:39
от vitasw
Как передать параметр дата начала и дата окончания в расшифровка отчета

Автор Inan1111Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 88
Последний ответ 26 Окт 2020, 01:37
от Inan1111
ОСВ по 20 счету (отсутствует расшифровка статей затрат на конец месяца )

Автор ирина56Раздел Пользователям "1С - Предприятие 8"

Ответов: 1
Просмотров: 5727
Последний ответ 02 Апр 2013, 17:23
от MuI_I_Ika

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

DmitriyF DmitriyF
31 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
28 Сообщений
alexandr_ll
20 Сообщений
MuI_I_Ika MuI_I_Ika
17 Сообщений
antoneus antoneus
10 Сообщений
LexaK
10 Сообщений
Yamuna
9 Сообщений
gribok
9 Сообщений
Дидар Оразалы Дидар Оразалы
9 Сообщений
Каримдат Каримдат
7 Сообщений

* Кто онлайн

  • Точка Гостей: 281
  • Точка Скрытых: 0
  • Точка Пользователей: 4
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal