Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
01 авг 2021, 13:02

Автозаполнение поля из другого документа

Автор flippo, 12 ноя 2020, 17:32

0 Пользователей и 1 гость просматривают эту тему.

flippo

Есть два документа:
1) ПредварительноеСоглашение там есть реквизит Организация
2) ОформлениеДоговора в этом документе нужно чтобы когда в реквизите Соглашение выбираешь записи из Документа, из этой строки которую я выбрал заполнялся реквизит Организация в документе ОформлениеДоговора

flippo

Решение
В форме модуля документа Оформление договора добавил: 
&НаКлиенте
Процедура СоглашениеПриИзменении(Элемент)
    Объект.Организация = ПолучитьПредварительноеСоглашение(Объект.Организация);
КонецПроцедуры

&НаСервереБезКонтекста
Функция ПолучитьПредварительноеСоглашение(Организация)
    Запрос = Новый Запрос;
    Запрос.Текст =
"ВЫБРАТЬ
| ПредварительноеСоглашение.Организация КАК Организация
|ИЗ
| Документ.ПредварительноеСоглашение КАК ПредварительноеСоглашение";

    Запрос.УстановитьПараметр("Организация", Организация);
    РезультатЗапроса = Запрос.Выполнить();
    Выборка = РезультатЗапроса.Выбрать();
    Если Выборка.Следующий() Тогда
        Возврат Выборка.Организация;
        Иначе
            Возврат "";
    КонецЕсли;
КонецФункции

LexaK

:D , попробуйте так

&НаКлиенте
Процедура СоглашениеПриИзменении(Элемент)
        Объект.Организация = ПолучитьОрганизациюСоглашения(Объект.Соглашение);
КонецПроцедуры
   
&НаСервереБезКонтекста
Функция ПолучитьОрганизациюСоглашения(Соглашение)
Возврат Соглашение.Организация;
КонецФункции
ответ Понравился? (в смысле пригодился?)

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск