Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
20 Май 2019, 05:34
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Уведомление о незаполнение свойства номенклатуры  (Прочитано 2248 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Апельсин

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-07
  • Сайт: 
  • Профессия: Программист 8.1
Доброго времени суток форумчане.
У меня много вопросов по программированию, но начнем с малого.
И так, у меня магазин автозапчастей, работаю в 1Спредприятие8.2 управление торговлей 10.3.
Вопрос в следующем, имеется карточка номенклатуры, на запчасть, я создал свойство для всех карточек что бы можно было вписать производителя. Так вот я хочу что бы когда я создаю новый элемент, и прожимаю ОК, и если я не заполняю эту графу, что бы он мне писал в сообщениях или в оповещениях что мол я не заполнил эту графу.
Жду Ваших предложений решения проблемы)))
http://imageshack.us/photo/my-images/849/75495828.jpg


Оффлайн chuevsf

  • Хочу! Хочу! Хочу! Мышь на палочке!
  • *****
  • Сообщений: 1379
  • РЕПУТАЦИЯ: 345
  • КПД: 25%
  • Регистрация: 2010-07-08
    • Skype: chuevsf
  • Сайт: 
  • Профессия: Программист 1С
В процедуре ПослеЗаписи()  запиши код, чтобы проверял заполнено или не заполнено.

Оффлайн Апельсин

  • *
  • Сообщений: 2
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-07
  • Сайт: 
  • Профессия: Программист 8.1
В процедуре ПослеЗаписи()  запиши код, чтобы проверял заполнено или не заполнено.
Если можно, на пальцах объясните пожалуйста.

Оффлайн zkolenko

  • **
  • Сообщений: 50
  • РЕПУТАЦИЯ: 17
  • КПД: 34%
  • Регистрация: 2010-08-02
  • Сайт: 
  • Профессия: Программист 8.1
//если вы хотите чтобы когда вы жмете ОК и при этом не заполнено свойство,
//отказаться от записи, и выдать предупреждение что свойство не заполнено,
//зачем лишний раз записывать недозаполненый документ,
//тогда  лучше следующий код:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   Если НЕ ЗначениеЗаполнено(СВОЙСТВО) Тогда
      Сообщить("Не заполнено свойство");
      Отказ = Истина;
   КонецЕсли;
КонецПроцедуры

//здесь мы проверяем заполнен ли реквизит СВОЙСТВО и если он не заполнен
//тогда отказыавется от записи и выводим сообщение
//или можно вывести вопрос во всплывающем окне где вы сами
//выбираете отказаться от записи или продолжить запись:

Процедура ПередЗаписью(Отказ, РежимЗаписи, РежимПроведения)
   Если НЕ ЗначениеЗаполнено(СВОЙСТВО) Тогда
      Ответ = Вопрос("Не заполнено значение реквизита СВОЙСТВО! Продолжить запись документа?", РежимДиалогаВопрос.ДаНет, 60, КодВозвратаДиалога.Нет, "Продолжить запись документа?");
      Отказ = ?(ответ = КодВозвратаДиалога.Нет, Истина, Ложь);
   КонецЕсли;
КонецПроцедуры


Теги:
 

"фильтрация" номенклатуры

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 12
Просмотров: 10447
Последний ответ 11 Мар 2014, 16:09
от mashencev_anton
Номенклатуры типов "расход" и "услуга. Как использовать?

Автор joyerРаздел Пользователям "1С - Предприятие 8"

Ответов: 0
Просмотров: 3205
Последний ответ 29 Июн 2011, 21:11
от joyer
Как в реализации товаров и услуг во вкладке товары добавить столбец производитель (FA) в управление торговлей 11.1 1с предприятие? оно отсутствует в номенклатуре доступной при нажатии кнопки добавить как войти в настройки номенклатуры?

Автор сергей123Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 239
Последний ответ 25 Янв 2019, 10:07
от сергей123
Добавление колонки в "Установку цен номенклатуры"

Автор EtherialРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 325
Последний ответ 23 Окт 2018, 17:35
от Etherial
1C УТ 8.3 релиз 11.1.7.49, проблема Номенклатуры с типом "Набор"

Автор cotevichРаздел Беседка

Ответов: 0
Просмотров: 3139
Последний ответ 22 Авг 2014, 10:33
от cotevich

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Автозапчасти

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
36 Сообщений
AIFrame AIFrame
31 Сообщений
alexandr_ll
29 Сообщений
wise wise
28 Сообщений
DmitriyF DmitriyF
13 Сообщений
vova-1c@xaker.ru
11 Сообщений
Eugeneer Eugeneer
9 Сообщений
Мария112689
8 Сообщений
kiksi
8 Сообщений
Yamuna
8 Сообщений

* Кто онлайн

  • Точка Гостей: 139
  • Точка Скрытых: 0
  • Точка Пользователей: 1
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal