Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 05:36

Помогите с разработкой документа по регистру накопления

Автор Алексей_1985_06, 07 ноя 2020, 18:47

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем большой привет! Прошу строго не судить и не кидаться камнями... Только учусь...
Прошу помочь с грамотной разработкой документа или может самого регистра накоплений "ОстаткиНоменклатуры" который должен вести учет количества товаров в разрезе сотрудников, номенклатуры и складов.
Сделал в регистре ресурс: количество, а измерение: Номенклатура, сотрудник, склад (с соответствующими ссылками на справочники)
Алгоритм движения номенклатуры в организации следующий:
1. Сотрудник может получить номенклатуру как со склада, так и от другого сотрудника (при передачи) котрорый получил ее ранее со склада. Соответствующие реквизиты в документе "Отпустил" (тип составной: склад, сотрудник) и "Получатель" (тип составной: склад, сотрудник). Получается что при проведении документа "ВыдачаНоменклатуры", с одного сотрудника (склада) номенклатура должна "списаться" а на другого наоборот "записаться".
Подскажите пожалуйста как правильно это сделать?
Скрины во вложении....

alexandr_ll

Цитата: Алексей_1985_06 от 07 ноя 2020, 18:47
Всем большой привет! Прошу строго не судить и не кидаться камнями... Только учусь...
Прошу помочь с грамотной разработкой документа или может самого регистра накоплений "ОстаткиНоменклатуры" который должен вести учет количества товаров в разрезе сотрудников, номенклатуры и складов.
Сделал в регистре ресурс: количество, а измерение: Номенклатура, сотрудник, склад (с соответствующими ссылками на справочники)
Алгоритм движения номенклатуры в организации следующий:
1. Сотрудник может получить номенклатуру как со склада, так и от другого сотрудника (при передачи) котрорый получил ее ранее со склада. Соответствующие реквизиты в документе "Отпустил" (тип составной: склад, сотрудник) и "Получатель" (тип составной: склад, сотрудник). Получается что при проведении документа "ВыдачаНоменклатуры", с одного сотрудника (склада) номенклатура должна "списаться" а на другого наоборот "записаться".
Подскажите пожалуйста как правильно это сделать?
Скрины во вложении....
Склад - это же не просто какое-то помещение, а место хранения материальных ценностей. Например: место хранения - "Офис", в нем несколько сотрудников. Также на месте хранения "Склад" есть сотрудник, который выдает и принимает номенклатуру. Другими словами реквизиты "Склад" и "Сотрудник" нужны оба и обязательно правильно заполненные.

Алексей_1985_06

 Спасибо, сделал в документе соответствующие реквизиты!
Подскажите, пожалуйста, как мне сделать чтобы документ "НакладнаяНаВнутренниеПеремещение" при проведении сделал запись со знаком "+" - для сотрудника который получил имущество и со знаком "-" - для сотрудника который это имущество передал?

Процедура ОбработкаПроведения(Отказ, Режим)
// регистр ОстаткиНоменклатуры Приход
Движения.ОстаткиНоменклатуры.Записывать = Истина;
Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;
Движение.Сотрудник = Получил;
Движение.Склад = СтруктурноеПодразделениеПолучатель;
Движение.Количество = ТекСтрокаСписокНоменклатуры.Количество;
Движение.Сумма = ТекСтрокаСписокНоменклатуры.Сумма;
КонецЦикла;
КонецПроцедуры

alexandr_ll

Цитата: Алексей_1985_06 от 08 ноя 2020, 17:30
Спасибо, сделал в документе соответствующие реквизиты!
Подскажите, пожалуйста, как мне сделать чтобы документ "НакладнаяНаВнутренниеПеремещение" при проведении сделал запись со знаком "+" - для сотрудника который получил имущество и со знаком "-" - для сотрудника который это имущество передал?

Процедура ОбработкаПроведения(Отказ, Режим)
// регистр ОстаткиНоменклатуры Приход
Движения.ОстаткиНоменклатуры.Записывать = Истина;
Для Каждого ТекСтрокаСписокНоменклатуры Из СписокНоменклатуры Цикл
Движение = Движения.ОстаткиНоменклатуры.Добавить();
Движение.ВидДвижения = ВидДвиженияНакопления.Приход;
Движение.Период = Дата;
Движение.Номенклатура = ТекСтрокаСписокНоменклатуры.Номенклатура;
Движение.Сотрудник = Получил;
Движение.Склад = СтруктурноеПодразделениеПолучатель;
Движение.Количество = ТекСтрокаСписокНоменклатуры.Количество;
Движение.Сумма = ТекСтрокаСписокНоменклатуры.Сумма;
КонецЦикла;
КонецПроцедуры

А в чем проблема? Также как сделали движение "Приход", также и движение "расход", только вид движения и реквизиты другие.

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск