Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 16:05

индекс строки

Автор margo, 06 ноя 2020, 18:50

0 Пользователей и 1 гость просматривают эту тему.

margo

Добрый день!

Подскажите, пожалуйста, как заполнить в цикле реквизит следующей строки из предыдущей

margo

Цитата: margo от 06 ноя 2020, 18:50
Добрый день!

Подскажите, пожалуйста, как заполнить в цикле реквизит следующей строки из предыдущей

пробывала вот так:
Для каждого ПланируемаяСтрока из ПланируемыеСтроки Цикл
                                    
ПланируемаяСтрока.Начало = Макс(ПланируемаяСтрока[ПланируемыеСтроки.ВГраница() - Индекс].Окончание, ПланируемаяСтрока.Начало);
                  
Индекс = Индекс + 1;

КонецЦикла;

АлександрВладимирович

примерно так:
ПредыдущаяДата = '00010101';
Для каждого СтрокаТаблицы Из ТЗилиТЧ Цикл
  СтрокаТаблицы.ДатаПредыдущегоДокумента = ПредыдущаяДата;
  ПредыдущаяДата = СтрокаТаблицы.ДатаДокумента;
КонецЦикла;

margo

Цитата: АлександрВладимирович от 07 ноя 2020, 18:13
примерно так:
ПредыдущаяДата = '00010101';
Для каждого СтрокаТаблицы Из ТЗилиТЧ Цикл
  СтрокаТаблицы.ДатаПредыдущегоДокумента = ПредыдущаяДата;
  ПредыдущаяДата = СтрокаТаблицы.ДатаДокумента;
КонецЦикла;


вот как раз и не получается. выходит так , что каждая строка заходящая в цикл имеет индек 0 всенда, и как получить (СтрокаТаблицы.ДатаДокумента - т.е. дату окончания) из предыдущей строки. тут не за цикл вопрос, а за использования индекса строки
Добавлено: 07 ноя 2020, 21:11


Цитата: АлександрВладимирович от 07 ноя 2020, 18:13
примерно так:
ПредыдущаяДата = '00010101';
Для каждого СтрокаТаблицы Из ТЗилиТЧ Цикл
  СтрокаТаблицы.ДатаПредыдущегоДокумента = ПредыдущаяДата;
  ПредыдущаяДата = СтрокаТаблицы.ДатаДокумента;
КонецЦикла;


спасибо, будем пробовать

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск