Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 05:37

Программирование с помощью запросов

Автор Lenochca, 04 ноя 2020, 22:46

0 Пользователей и 1 гость просматривают эту тему.

Lenochca

Здравствуйте, коллеги!
Помогите, пожалуйста, решить проблему.
Ситуация следующая, мне нужно вывести первую букву наименования справочника при открытии формы списка именно через Запрос.
Помогите поправить ниже представленный код для озвученной ранее задачи. Огромное Спасибо.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Анкета.Ссылка
      |ИЗ
      |   Справочник.Анкета КАК Анкета
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Сообщить();
   КонецЦикла;

КонецПроцедуры

alexandr_ll

Первая буква в наименовании справочника "Анкета"="А", поэтому Сообщить("А");

Optiman

Сообщить(Лев(ВыборкаДетальныеЗаписи.Ссылка, 1));

antoneus

ВЫБРАТЬ ПОДСТРОКА(Анкета.Наименование, 1, 1)

DNN

Правильно делать в ПриСозданииНаСервере, а не ПриОткрытии

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск