Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
01 Дек 2020, 08:00
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Программирование с помощью запросов  (Прочитано 207 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн Lenochca

  • *
  • Сообщений: 0
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-11-04
  • Сайт: 
  • Профессия: Программист 1С
Здравствуйте, коллеги!
Помогите, пожалуйста, решить проблему.
Ситуация следующая, мне нужно вывести первую букву наименования справочника при открытии формы списка именно через Запрос.
Помогите поправить ниже представленный код для озвученной ранее задачи. Огромное Спасибо.

&НаКлиенте
Процедура ПриОткрытии(Отказ)
   ПриОткрытииНаСервере();
КонецПроцедуры

&НаСервере
Процедура ПриОткрытииНаСервере()

   Запрос = Новый Запрос;
   Запрос.Текст =
      "ВЫБРАТЬ
      |   Анкета.Ссылка
      |ИЗ
      |   Справочник.Анкета КАК Анкета
   
   РезультатЗапроса = Запрос.Выполнить();
   
   ВыборкаДетальныеЗаписи = РезультатЗапроса.Выбрать();
   
   Пока ВыборкаДетальныеЗаписи.Следующий() Цикл
      Сообщить();
   КонецЦикла;

КонецПроцедуры


Оффлайн alexandr_ll

  • *****
  • Сообщений: 1455
  • РЕПУТАЦИЯ: 212
  • КПД: 15%
  • Регистрация: 2016-08-23
  • Сайт: 
  • Профессия: Программист 1С
Первая буква в наименовании справочника "Анкета"="А", поэтому
Сообщить("А");

Оффлайн Optiman

  • **
  • Сообщений: 66
  • РЕПУТАЦИЯ: 2
  • КПД: 3%
  • Регистрация: 2011-10-12
  • Сайт: 
  • Профессия: Программист 1С
Сообщить(Лев(ВыборкаДетальныеЗаписи.Ссылка, 1));

Оффлайн antoneus

  • ****
  • Сообщений: 397
  • РЕПУТАЦИЯ: 105
  • КПД: 26%
  • Регистрация: 2018-11-22
  • Сайт: 
  • Профессия: Программист 1С
ВЫБРАТЬ ПОДСТРОКА(Анкета.Наименование, 1, 1)

Оффлайн DNN

  • https://program1s.com/
  • *
  • Сообщений: 3
  • РЕПУТАЦИЯ: 0
  • https://program1s.com/
  • Регистрация: 2020-11-17
  • Сайт: program1s.com
  • Профессия: Программист 1С
Правильно делать в ПриСозданииНаСервере, а не ПриОткрытии


Теги:
 

Для объекта не определена форма по умолчанию, соответствующая текущему режиму запуска. Объект: "Консоль Запросов"

Автор Азамат ХубиевРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 15121
Последний ответ 20 Июл 2016, 22:56
от Азамат Хубиев
Возможно ли языком запросов без конкатенации текста запроса и без СКД преобразовать строки таблицы в столбцы (колонки) выходной таблицы?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 2065
Последний ответ 29 Май 2017, 15:29
от alex0402
Какую консоль запросов используете вы в управляемом приложении или что за консоль в видео?

Автор acces969Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 1
Просмотров: 1228
Последний ответ 17 Апр 2017, 09:40
от LexaK
Консоль запросов ошибка {(1, 1)}: Ожидается выражение "ВЫБРАТЬ"

Автор BigzoneРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 2472
Последний ответ 03 Дек 2018, 04:17
от Bigzone
Начинающий/Внешний отчет СКД/Обработка результата запроса, объединение результатов, арифметические операции с участием данных нескольких запросов

Автор Дмитрий СозыкинРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 676
Последний ответ 15 Янв 2019, 23:50
от Дмитрий Созыкин

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

DmitriyF DmitriyF
31 Сообщений
Геннадий ОбьГЭС Геннадий ОбьГЭС
28 Сообщений
alexandr_ll
20 Сообщений
MuI_I_Ika MuI_I_Ika
17 Сообщений
antoneus antoneus
10 Сообщений
LexaK
10 Сообщений
Дидар Оразалы Дидар Оразалы
9 Сообщений
gribok
9 Сообщений
Yamuna
9 Сообщений
Каримдат Каримдат
7 Сообщений

* Кто онлайн

  • Точка Гостей: 249
  • Точка Скрытых: 0
  • Точка Пользователей: 2
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal