Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
29 июл 2021, 15:42

Обработка выделенных строк при множественном выборе

Автор SEMEN-YU, 30 окт 2020, 12:36

0 Пользователей и 1 гость просматривают эту тему.

SEMEN-YU

Добрый день, Коллеги. Прошу вашей помощи по такому вопросу
Конфигурация УПП, обычное приложение.
Необходимо заполнение табличной части РТУ из списка выбора другого документа при множественном выборе
ФормаВыбора = Документы.ДокументЗаполнения.ПолучитьФормуВыбора();
ФормаВыбора.Заголовок   = "Выберите документ  для заполнения";
ФормаВыбора.РежимВыбора = Истина;
ФормаВыбора.ЗакрыватьПриВыборе=Ложь;
ФормаВыбора.МножественныйВыбор=Истина;
ФормаВыбора.ОткрытьМодально();
        ВыделенныеСтроки=ФормаВыбора.ЭлементыФормы.ДокументСписок.ВыделенныеСтроки;
         Для Каждого Стр из ВыделенныеСтроки Цикл
           Для Каждого СтрокаТЧ Из ДокументРеализации.Товары Цикл  //вот тут проблема, не могу добраться до ТЧ ДокументЗаполнения
НоваяСтрока = Товары.Добавить();
ЗаполнитьЗначенияСвойств( НоваяСтрока, СтрокаТЧ);
   КонецЦикла;
КонецЦикла;

Подскажите пожалуйста как добраться до ТЧ ДокументаЗаполнения
Заранее спасибо.

ls600

Цитата: SEMEN-YU от 30 окт 2020, 12:36ДокументРеализации
Судя по коду будет ошибка Переменная не определена.

Иногда пользователям нет предела фантазии))) что только не придумают :D



LexaK

вообще было бы правильным, данные запросом получить,
но можно и так вы делаете, почти все правильно сделали
только от переменной Стр надо брать ссылку на документ, посмотрите в отладчике как она называется и замените вашу ДокументРеализации на правильное название
не помню уже как это в обычных формах, возможно Стр - это сама ссылка на документ (тогда Стр.Товары)
короче, под отладчиком 5 секунд, посмотреть что за тип Стр и какие в ней поля

Для Каждого Стр из ВыделенныеСтроки Цикл
    Для Каждого СтрокаТЧ Из Стр.ДокументРеализации.Товары Цикл  //вот тут от Стр проблема, не могу добраться до ТЧ ДокументЗаполнения
    НоваяСтрока = Товары.Добавить();
    ЗаполнитьЗначенияСвойств( НоваяСтрока, СтрокаТЧ);
    КонецЦикла;
    КонецЦикла;
ответ Понравился? (в смысле пригодился?)

SEMEN-YU

Спасибо
До ТЧ добрался, но теперь проблема - выделяю строки в Форме выбора , при нажатии на Выбрать они не добавляются, только при закрытии формы . Может что то не дописал в этом месте?
ФормаВыбора.Заголовок   = "Выберите документ  для заполнения";
    ФормаВыбора.РежимВыбора = Истина;
    ФормаВыбора.ЗакрыватьПриВыборе=Ложь;
    ФормаВыбора.МножественныйВыбор=Истина;
    ФормаВыбора.ОткрытьМодально();

ls600

ФормаВыбора.ЗакрыватьПриВыборе=Ложь; если за комментировать код.
После выбора нужных документов и нажатия кнопки Выбрать. Данные добавятся, окно закроется автоматически.

SEMEN-YU


Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск