Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
16 Дек 2017, 04:48
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Помогите новичку  (Прочитано 2382 раз)

0 Пользователей и 1 Гость просматривают эту тему.

Оффлайн gopsmile

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Платформа 7.7 (7.70.027)
Конфигурация  ТиС (Торговля и склад) (7.70.941)

Отчет остатки ТМЦ

ТМЦ                            Магазин 1                Магазин 2              Магазин 3                 Склад (Основной)           Новая Колонка
                                  Кол-во  Сумма          Кол-во  Сумма        Кол-во  Сумма           Кол-во  Сумма               Сумма (По Всем Магазинам)
Наименование 1               1          20                 2         10              3          10                4         23                 Сумма (По Всем Магазинам)
Наименование 2               3          10                 1         30              4          30                2         22                 
...
Итого                             4           30                 3         40              7          40                6         45                Сумма (По Всем Магазинам)


Прошу прошения за предыдущую тему, не смог удалить.

Не подскажете как добавить Новую колонку и посчитать сумму по все магазинам кроме основного склада.


Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите новичку
« Ответ #1: 07 Май 2011, 01:28 »
Сумма как должна получаться? цена какая берется за основу?

Оффлайн gopsmile

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите новичку
« Ответ #2: 10 Май 2011, 09:14 »
Сумма берется скажем из справочника цен - закупочные

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите новичку
« Ответ #3: 10 Май 2011, 13:37 »
ну это не сложно, запросы составлял когда нить?

Оффлайн prog1c7.7

  • Модератор
  • *****
  • Сообщений: 784
  • РЕПУТАЦИЯ: 260
  • КПД: 33%
  • ну - да , ну - да...
  • Регистрация: 2010-10-20
  • Сайт: 
  • Профессия: Программист 1С
Re: Помогите новичку
« Ответ #4: 10 Май 2011, 13:47 »
//вернее нужен запрос по регистру остаткитмц на определенную дату , с группировкой по складу, это легко можно //даже конструктором.
//а вот цены брать щас объясню как (для любых типов, я гдето писал такое уже):
//1.вешай на форму поле с выбором - обзови  "ТипЦеныТек", тип - справ. ТипыЦен
//2. в модуле:(в данном случае спрном1 - это спр. номенклатура)
// Ищем цены на период отчета по типу цен
   Цены = СоздатьОбъект("Справочник.Цены");   
   Цены.ИспользоватьВладельца(СпрНом1.ТекущийЭлемент());
   Цены.ВыбратьЭлементы();
   
   Пока Цены.ПолучитьЭлемент()  = 1 Цикл   
      Если ТипЦеныТек.Рассчитывается = 1  тогда

      
      СпрТипыЦен = СоздатьОбъект("Справочник.ТипыЦен");
       СпрТипыЦен.ВыбратьЭлементы();
      Пока СпрТипыЦен.ПолучитьЭлемент() = 1 Цикл         
      Если (СпрТипыЦен.ТекущийЭлемент() = ТипЦеныТек) Тогда
         // Если цена рассчитывается
         Если глВернутьЦену(СпрНом1.ТекущийЭлемент(), ТипЦеныТек, ДатаОтчета, ЦенаЦены, ЕдЦены, ) = 1 Тогда
            
         
            РеалЦенаОб         = ТипЦеныТек;
            РеалЦена           = ЦенаЦены;
            Прервать;
         КонецЕсли;
      КонецЕсли;
       КонецЦикла;
      

      
       ИначеЕсли ТипЦеныТек.Рассчитывается <> 1 Тогда
         Если Цены.ТипЦен <> ТипЦеныТек Тогда
             Продолжить;
          КонецЕсли;
           РеалЦенаОб = Цены.ТекущийЭлемент();
            РеалЦена = РеалЦенаОб.Цена.Получить(ДатаОтчета);
   
       КонецЕсли;   
   КонецЦикла;

//3. Т.е. будет в зависимости от выбранного типа цен у тебя актуальная цена на определенную дату - РеалЦена

Оффлайн gopsmile

  • *
  • Сообщений: 4
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2011-05-05
  • Сайт: 
  • Профессия: Ученик 1С
Re: Помогите новичку
« Ответ #5: 10 Май 2011, 15:46 »
//// ну это не сложно, запросы составлял когда нить?

В этом то и беда, не составлял. Ну буду разбираться, с синтаксисом никак не разберусь. Если долго долго мучиться что нить получиться. Большое Вам спасибо.


Теги:
 


* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
154 Сообщений
ilyay ilyay
66 Сообщений
alex0402
53 Сообщений
AIFrame
46 Сообщений
andron81_81
44 Сообщений
oleg-x
44 Сообщений
BuhRust
32 Сообщений
MuI_I_Ika MuI_I_Ika
32 Сообщений
Golickoff Golickoff
31 Сообщений
Dima Dddd Dima Dddd
24 Сообщений

* Кто онлайн

  • Точка Гостей: 129
  • Точка Скрытых: 0
  • Точка Пользователей: 0

Нет пользователей онлайн.

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal