Реклама на этом месте
Форум 1С
Форум 1С
Программистам. Бухгалтерам. Администраторам. Пользователям
Задай вопрос - получи решение проблемы. Без троллинга и флуда.
22 Окт 2020, 11:50
МультиВход
Добро пожаловать, Гость. Пожалуйста, войдите или зарегистрируйтесь.
Не получили письмо с кодом активации?
 
collapse

Автор Тема: Обезличивание данных. Скрытие персональной информации. Нужна срочная помощь.  (Прочитано 453 раз)

0 Пользователей и 5 Гостей просматривают эту тему.

Оффлайн Varlant1n

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Здравствуйте, дорогие друзья форумчане! Я уже писал про это пару тем назад, но тема стала неинтересной никому и поэтому упала вниз, без ответов. Я в данный момент учусь 1С в копании, будучи на практике. И передо мной стоит задача сделать ОбщуюКоманду, которая при нажатии обезличит все данные и в справочниках и в документах и вообще везде. То есть после нажатия все данные должны превратиться во что-то по типу "Наименование1, Наименование2 и тд...." Я прекрасно знаю, что есть уже готовые обработки для данной задачи, но мне же поставили задачу сделать то самому в виде команды, чтобы была кнопка, при нажатии на которую произойдёт выше сказанное. Прошу вас помочь мне с решением данной задачи. Можете хотя бы в виде тегов написать план действий, который нужно сделать, что добиться этого. Заранее огромное спасибо. Буду очень благодарен!


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 7120
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Предлагаю стандартную обработку встроить в вашу конфигурацию. А дальше вы можете просто вызывать ее командой.

Оффлайн Varlant1n

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Предлагаю стандартную обработку встроить в вашу конфигурацию. А дальше вы можете просто вызывать ее командой.

Спасибо за ваш совет! Но это задание, которое будет проверяться и следовательно это должен быть мой код с нуля. Я поэтому и просил помощи. Чтобы мне посоветовали ход действий.

Оффлайн IL2016

  • **
  • Сообщений: 85
  • РЕПУТАЦИЯ: 12
  • КПД: 14%
  • Регистрация: 2016-02-20
  • Сайт: 
  • Профессия: Ученик 1С
передо мной стоит задача сделать ОбщуюКоманду, которая при нажатии обезличит все данные и в справочниках и в документах и вообще везде.
На чем Вы будете её реализовывать? Наверное менять наименования придется только в справочниках, а дальше платформа сама поменяет по ссылкам. Полагаю что это проверка на умение использовать метаданные.
Использую учебную платформу 1С:Предприятие 8.3

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 7120
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
Тогда в обработке надо пробежаться по всем метаданным циклом. Так же по всем их реквизитам и табличным частям.

Выбираете каждый элемент объекта.

И там уже меняете все текстовые поля.

Оффлайн Varlant1n

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Тогда в обработке надо пробежаться по всем метаданным циклом. Так же по всем их реквизитам и табличным частям.

Выбираете каждый элемент объекта.

И там уже меняете все текстовые поля.

Вот, что я написал, но почему-то это не работает

&НаКлиенте
Процедура КнопкаСмерти(Команда)

КнопкаСмертиНаСервере();


КонецПроцедуры

&НаСервере
Процедура КнопкаСмертиНаСервере()

Для Каждого МетаданноеСправочника Из Метаданные.Справочники Цикл
Выборка = Справочники[МетаданноеСправочника.Имя].Выбрать();
Пока Выборка.Следующий() Цикл

МетаданноеОбъект = Выборка.ПолучитьОбъект();

МассивСтандартныхРеквизитов = Новый Массив;
Если МетаданноеСправочника.ДлинаКода > 0 Тогда
МассивСтандартныхРеквизитов.Добавить(Новый Структура("Имя", "Код"));
КонецЕсли;
Если МетаданноеСправочника.ДлинаНаименования > 0 Тогда
МассивСтандартныхРеквизитов.Добавить(Новый Структура("Имя", "Наименование"));
КонецЕсли;
ОчиститьДанные(МетаданноеОбъект, МассивСтандартныхРеквизитов);

ОчиститьДанные(МетаданноеОбъект, МетаданноеСправочника.Реквизиты);

МетаданноеОбъект.ОбменДанными.Загрузка = Истина;
МетаданноеОбъект.Записать();

КонецЦикла;
КонецЦикла;


КонецПроцедуры

&НаСервере
Процедура ОчиститьДанные(МетаданноеОбъект, НаборРеквизитов)
   
    Для Каждого МетаданноеРеквизит Из НаборРеквизитов Цикл
       
        Если ТипЗнч(МетаданноеОбъект[МетаданноеРеквизит.Имя]) = Тип("Строка") Тогда
           
            МетаданноеОбъект[МетаданноеРеквизит.Имя] = "авбгд";
           
        КонецЕсли;
       
    КонецЦикла;
   
КонецПроцедуры


Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 7120
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С
А выдает какую-то ошибку. Если нет, то поставь те точку остановки в строку МетаданноеОбъект.Записать(); и посмотрите на значения реквизитов объекта.

Оффлайн Varlant1n

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-10-07
  • Сайт: 
  • Профессия: Ученик 1С
А выдает какую-то ошибку. Если нет, то поставь те точку остановки в строку МетаданноеОбъект.Записать(); и посмотрите на значения реквизитов объекта.

Нет, ошибку никакую не выдает и никаких значений реквизитов то же нет. Я думал, что ошибка может быть в том, что это общая команда и попробовал создать внешнюю обработку и вставить эту команду там, но опять ничего не работает

Оффлайн MuI_I_Ika

  • Гончаров Михаил
  • Администратор
  • *****
  • Сообщений: 7120
  • РЕПУТАЦИЯ: 845
  • КПД: 12%
  • Регистрация: 2012-08-15
    • Skype: MuI_I_Ika
  • Сайт: 
  • Профессия: Программист 1С

Оффлайн Varlant1n

  • *
  • Сообщений: 12
  • РЕПУТАЦИЯ: 0
  • Регистрация: 2020-10-07
  • Сайт: 
  • Профессия: Ученик 1С
Ну точка останова то работает?

Нет, в локальных переменных всё пусто.


Теги:
 

Перенос данных из 1с 82 БП (базовая) в 1с 82 БГУ (базовая)

Автор Владимир87Раздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 9812
Последний ответ 06 Дек 2014, 17:40
от дфтын
Поиск по бае данных,(полнотекстовый поиск)

Автор kot_ooРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 0
Просмотров: 4955
Последний ответ 19 Май 2014, 15:40
от kot_oo
Как исправить при обновлении ИБ: Ошибка в запросе набора данных по причине: {(58, 2)}: Несовместимые типы "ВЫБОР" <<?>>ВЫБОР

Автор dollРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 4
Просмотров: 4658
Последний ответ 26 Апр 2018, 06:45
от Геннадий ОбьГЭС
"Задваивание" данных в отчете

Автор mashencev_antonРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 14
Просмотров: 11864
Последний ответ 12 Июл 2020, 14:17
от karogach
Куда сохраняются данные в режиме работы клиент при выгрузке данных обработкой "Универсальный обмен данными в формате XML"

Автор xDDРаздел Конфигурирование, программирование в "1С - Предприятие 8"

Ответов: 3
Просмотров: 10990
Последний ответ 13 Ноя 2014, 08:23
от cska-fanat-kz

* Живое общение

Не устроил ответ?

Зарегистрируйся и задай свой вопрос. Живое общение приносит результат намного быстрее.


Зарегистрироваться

* Реклама

* Поиск

* Последние задачи на разработку (фриланс)

* Реклама

* Последние вакансии

* Топ 10 авторов за месяц

Геннадий ОбьГЭС Геннадий ОбьГЭС
82 Сообщений
IL2016
32 Сообщений
antoneus antoneus
31 Сообщений
alexandr_ll
22 Сообщений
DmitriyF DmitriyF
20 Сообщений
MuI_I_Ika MuI_I_Ika
16 Сообщений
Varlant1n
15 Сообщений
Дмитрий Джей Дмитрий Джей
13 Сообщений
Алексей_1985_06
12 Сообщений
oooo800
10 Сообщений

* Кто онлайн

  • Точка Гостей: 701
  • Точка Скрытых: 0
  • Точка Пользователей: 3
  • Точка Сейчас на форуме:

* Облако тэгов

* Форум 1С с мобильного

* Инструменты

* Дополнительно

Поиск

 
SimplePortal 2.3.5 © 2008-2012, SimplePortal