Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 06:17

Красиво сообщить пользователю на сервере УФ

Автор skillful, 11 окт 2020, 18:41

0 Пользователей и 1 гость просматривают эту тему.

skillful

Здравствуйте. Как вывести сообщение как на скриншоте именно на &НаСервере. Подойдут любые варианты с примерами, чтобы работало на толстом, тонком и вебклиенте.

antoneus

Никак. Если только исключение вызывать с красным кружочком.

skillful

Цитата: antoneus от 11 окт 2020, 20:02
Никак. Если только исключение вызывать с красным кружочком.
Что за красный кружочек? :dfbbdrfb:

antoneus


skillful

Цитата: antoneus от 11 окт 2020, 20:02
Никак. Если только исключение вызывать с красным кружочком.
Что значит Никак?
Процедура ПроверкаНаПустойПароль() Экспорт

ПользовательИБПарольУстановлен = УправлениеПользователямиСервер.ПроверкаНаПустойПароль();

Если ПользовательИБПарольУстановлен = Ложь Тогда
Предупреждение = "Пароль входа в систему не установлен! Необходимо ввести пароль.";
Оповещение = Новый ОписаниеОповещения("ПослеЗакрытияПредупрежденияОПустомПароле", ЭтотОбъект, "");
ПоказатьПредупреждение(Оповещение, Предупреждение);

КонецЕсли;

КонецПроцедуры

&НаКлиенте
Процедура ПослеЗакрытияПредупрежденияОПустомПароле(Параметры) Экспорт
Парам = Новый Структура("ОтменаРазрешена", Ложь);
ФормаПароля = ПолучитьФорму("ОбщаяФорма.ВводПароля", Парам);
ФормаПароля.Открыть();
КонецПроцедуры

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск