Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 04:47

Ошибка: Итератор не определен

Автор Алексей_1985_06, 07 окт 2020, 19:01

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем доброго времени суток. Помогите с задачкой, при открытии формы списка Справочника, необходимо в полях где значение поля "Должность" не заполнено (из регистра сведений) - нужно написать "нет данных". При таком варианте выходит ошибка:

err {Справочник.Сотрудники.Форма.ФормаСписка.Форма(13)}: Итератор для значения не определен
   Для каждого Строка Из Список Цикл

Подскажите пожалуйста, как правильно реализовать?

&НаКлиенте
Процедура ПриОткрытии(Отказ)
    Для каждого Строка Из Список Цикл
        Если Строка.Должность = ""  Тогда
    Строка.Должность = "нет данных"
        КонецЕсли;
            КонецЦикла;
КонецПроцедуры


antoneus

Так не пойдет, надо запрос динамического списка перепиливать.

Алексей_1985_06

Цитата: antoneus от 07 окт 2020, 19:59
Так не пойдет, надо запрос динамического списка перепиливать.

Аntoneus, извините, а можете подсказать что надо "допилить"? Запрос динамического списка такой:
ВЫБРАТЬ
СправочникСотрудники.Ссылка КАК Ссылка,
СправочникСотрудники.Наименование КАК Наименование,
СправочникСотрудники.ДатаРождения КАК ДатаРождения,
ПослужнойСписокСрезПоследних.Подразделение КАК Подразделение,
ПослужнойСписокСрезПоследних.Должность КАК Должность,
ВоинскиеЗванияСрезПоследних.ВоинскоеЗвание КАК ВоинскоеЗвание
ИЗ
Справочник.Сотрудники КАК СправочникСотрудники
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПослужнойСписок.СрезПоследних(, ) КАК ПослужнойСписокСрезПоследних
ПО СправочникСотрудники.Ссылка = ПослужнойСписокСрезПоследних.Сотрудник
ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ВоинскиеЗвания.СрезПоследних КАК ВоинскиеЗванияСрезПоследних
ПО СправочникСотрудники.Ссылка = ВоинскиеЗванияСрезПоследних.Сотрудник


antoneus

Ну, можно попробовать так

ВЫБРАТЬ
    СправочникСотрудники.Ссылка КАК Ссылка,
    СправочникСотрудники.Наименование КАК Наименование,
    СправочникСотрудники.ДатаРождения КАК ДатаРождения,
    ПослужнойСписокСрезПоследних.Подразделение КАК Подразделение,
    ВЫБОР КОГДА ПослужнойСписокСрезПоследних.Должность ЕСТЬ NULL
        ТОГДА "нет данных" ИНАЧЕ
    ПослужнойСписокСрезПоследних.Должность КОНЕЦ КАК Должность,
    ВоинскиеЗванияСрезПоследних.ВоинскоеЗвание КАК ВоинскоеЗвание
    ИЗ
    Справочник.Сотрудники КАК СправочникСотрудники
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПослужнойСписок.СрезПоследних(, ) КАК ПослужнойСписокСрезПоследних
        ПО СправочникСотрудники.Ссылка = ПослужнойСписокСрезПоследних.Сотрудник
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ВоинскиеЗвания.СрезПоследних КАК ВоинскиеЗванияСрезПоследних
        ПО СправочникСотрудники.Ссылка = ВоинскиеЗванияСрезПоследних.Сотрудник

Добавлено: 08 окт 2020, 15:22


то есть, конечно же

ЕСТЬNULL(ПослужнойСписокСрезПоследних.Должность, "нет данных") КАК Должность

Алексей_1985_06

Цитата: antoneus от 07 окт 2020, 22:33
Ну, можно попробовать так

ВЫБРАТЬ
    СправочникСотрудники.Ссылка КАК Ссылка,
    СправочникСотрудники.Наименование КАК Наименование,
    СправочникСотрудники.ДатаРождения КАК ДатаРождения,
    ПослужнойСписокСрезПоследних.Подразделение КАК Подразделение,
    ВЫБОР КОГДА ПослужнойСписокСрезПоследних.Должность ЕСТЬ NULL
        ТОГДА "нет данных" ИНАЧЕ
    ПослужнойСписокСрезПоследних.Должность КОНЕЦ КАК Должность,
    ВоинскиеЗванияСрезПоследних.ВоинскоеЗвание КАК ВоинскоеЗвание
    ИЗ
    Справочник.Сотрудники КАК СправочникСотрудники
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ПослужнойСписок.СрезПоследних(, ) КАК ПослужнойСписокСрезПоследних
        ПО СправочникСотрудники.Ссылка = ПослужнойСписокСрезПоследних.Сотрудник
        ЛЕВОЕ СОЕДИНЕНИЕ РегистрСведений.ВоинскиеЗвания.СрезПоследних КАК ВоинскиеЗванияСрезПоследних
        ПО СправочникСотрудники.Ссылка = ВоинскиеЗванияСрезПоследних.Сотрудник

Добавлено: 08 окт 2020, 15:22


то есть, конечно же

ЕСТЬNULL(ПослужнойСписокСрезПоследних.Должность, "нет данных") КАК Должность

Antoneus большое Вам спасибо!!!

Теги:

Похожие темы (5)

Рейтинг@Mail.ru Rambler's Top100

Поиск