Форум 1С
Программистам, бухгалтерам, администраторам, пользователям
Задай вопрос - получи решение проблемы
25 июл 2021, 06:14

Поместить данные:строка, в тип:ссылка

Автор Алексей_1985_06, 05 окт 2020, 17:34

0 Пользователей и 1 гость просматривают эту тему.

Алексей_1985_06

Всем доброго времени суток, подскажите пожалуйста, такой вопрос:
1. В рег.сведений "ПослужнойСписок" есть реквизит "Приказ" с типом:СправочникСсылка.ДолжностныеЛица
2. Необходимо при выборе должностного лица, просклонять его в родительном падеже (см.вложение)
Например: в справочнике: Начальник отдела; в рег.сведений: приказ - начальникА отдела
Вся проблема, что склонение получается с типом: строка и не записывается....
Составной тип данных, делать не хочется... как-то можно решить этот вопрос? Знатоков прошу подсказать!!!!!

Код:
В общем модуле "ВызовСервера" функция
// Функция которая получает необходимое склонение
&НаСервере
Функция ПолучитьСклонение(Реквизит,Падеж)Экспорт
Если 
Падеж = "Именительный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Именительный");
Результат = Склонение [0];
ИначеЕсли
Падеж = "Родительный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Родительный");
Результат = Склонение [0];
ИначеЕсли
Падеж = "Дательный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Дательный");
Результат = Склонение [0];
ИначеЕсли
Падеж = "Винительный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Винительный");
Результат = Склонение [0];
ИначеЕсли
Падеж = "Творительный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Творительный");
Результат = Склонение [0];
ИначеЕсли
Падеж = "Предложный" Тогда
Склонение = ПолучитьСклоненияСтроки(Реквизит, "Л=ru_RU", "ПД=Предложный");
Результат = Склонение [0];
КонецЕсли;
Возврат Результат;
КонецФункции


В модуле формы регистра сведений
&НаКлиенте
Процедура ПриказПриИзменении(Элемент)
Запись.Приказ = ВызовСервера.ПолучитьСклонение(Запись.Приказ, "Родительный");
КонецПроцедуры

antoneus

А в справочник если реквизит добавить? Или свойство какое дополнительное? И в форме списка регистра выводить этот реквизит.

Алексей_1985_06

Цитата: antoneus от 05 окт 2020, 17:55
А в справочник если реквизит добавить? Или свойство какое дополнительное? И в форме списка регистра выводить этот реквизит.

Хотелось бы чтоб в справочнике было написано: Начальник .... или Старший инженер .... (именительный падеж), а при выборе уже было : приказ Начальника.... приказ Старшего инженера и т.д. Строку никак нельзя "запихнуть" в реквизит с типом: Справочник.Ссылка?

antoneus

>при выборе

Значит, открывается форма выбора? А на ней динамический список? В который можно выводить любые реквизиты? В справочнике добавьте строковый реквизит "Склонение", туда пишите склоненную должность и в списке в форме выбора выводите этот реквизит вместо наименования. Или я все неправильно понял?

IL2016

наверное надо подумать на применение функций Прав, Лев при анализе должности.
Использую учебную платформу 1С:Предприятие 8.3

Теги:

Похожие темы (4)

Рейтинг@Mail.ru Rambler's Top100

Поиск